summary refs log tree commit diff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-05-17 00:20:17 -0400
committerLeo Famulari <leo@famulari.name>2016-05-17 13:18:15 -0400
commitfb2b0f5c87321f5aab0dc13130ef92a76040fbe3 (patch)
tree79c7c042cd0cb6319122bbefa135942612519fce /gnu/packages/gd.scm
parentbbb5d8aeea213f32e51ae18407aa8941f18a010b (diff)
downloadguix-fb2b0f5c87321f5aab0dc13130ef92a76040fbe3.tar.gz
gnu: gd: Fix-CVE-2016-3074.
* gnu/packages/patches/gd-CVE-2016-3074.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/gd.scm (gd)[source]: Use it.
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 769e7cecf2..e52a030f86 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -48,7 +49,8 @@
                    "libgd-" version ".tar.xz"))
              (sha256
               (base32
-               "11djy9flzxczphigqgp7fbbblbq35gqwwhn9xfcckawlapa1xnls"))))
+               "11djy9flzxczphigqgp7fbbblbq35gqwwhn9xfcckawlapa1xnls"))
+             (patches (search-patches "gd-CVE-2016-3074.patch"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))