summary refs log tree commit diff
path: root/gnu/packages/gdb.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-12 20:53:14 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-12 20:54:18 +0200
commit4a38ec9e98e2ca6dc1f01824b9097e0e668b48ab (patch)
tree0870904d0d486674e3ea6cd2ea0a22e0d4db6bd5 /gnu/packages/gdb.scm
parent2b8491fbbe818944baf454faf1326034022ac320 (diff)
downloadguix-4a38ec9e98e2ca6dc1f01824b9097e0e668b48ab.tar.gz
gnu: Remove GDB@8.2.
* gnu/packages/gdb.scm (gdb-8.2): Rename to ...
(gdb-8.3): ... this.  Update to 8.3.1.
(gdb): Refer to GDB-8.3.
Diffstat (limited to 'gnu/packages/gdb.scm')
-rw-r--r--gnu/packages/gdb.scm20
1 files changed, 4 insertions, 16 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 48d1c0da6b..66bdb81a74 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -34,17 +34,17 @@
   #:use-module (guix download)
   #:use-module (guix build-system gnu))
 
-(define-public gdb-8.2
+(define-public gdb-8.3
   (package
     (name "gdb")
-    (version "8.2.1")
+    (version "8.3.1")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/gdb/gdb-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "00i27xqawjv282a07i73lp1l02n0a3ywzhykma75qg500wll6sha"))))
+               "1i2pjwaafrlz7wqm40b4znr77ai32rjsxkpl2az38yyarpbv8m8y"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f ; FIXME "make check" fails on single-processor systems.
@@ -106,19 +106,7 @@ the program is running to try to fix bugs.  It can be used to debug programs
 written in C, C++, Ada, Objective-C, Pascal and more.")
     (license gpl3+)))
 
-(define-public gdb-8.3
-  (package
-    (inherit gdb-8.2)
-    (version "8.3.1")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://gnu/gdb/gdb-"
-                                  version ".tar.xz"))
-              (sha256
-               (base32
-                "1i2pjwaafrlz7wqm40b4znr77ai32rjsxkpl2az38yyarpbv8m8y"))))))
-
 (define-public gdb
   ;; This is the fixed version that packages depend on.  Update it rarely
   ;; enough to avoid massive rebuilds.
-  gdb-8.2)
+  gdb-8.3)