summary refs log tree commit diff
path: root/gnu/packages/gdb.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-05-13 10:09:36 +0200
committerLudovic Courtès <ludo@gnu.org>2019-05-13 10:12:14 +0200
commita8e7ba75366f6f49e50c4348ab4057b7789e1e92 (patch)
tree2784aa0838328dab6c0ab504fa51b0372131a61a /gnu/packages/gdb.scm
parent3ed497d42a5af8756bd95c64f9f9bed4de5f6d3c (diff)
downloadguix-a8e7ba75366f6f49e50c4348ab4057b7789e1e92.tar.gz
gnu: gdb: Add version 8.3.
* gnu/packages/gdb.scm (gdb): Rename to...
(gdb-8.2): ... this.
(gdb-8.3): New variable.
(gdb): Define as an alias for GDB-8.2.
Diffstat (limited to 'gnu/packages/gdb.scm')
-rw-r--r--gnu/packages/gdb.scm21
1 files changed, 19 insertions, 2 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index e9df33e3fc..5697664491 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2019 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
@@ -34,7 +34,7 @@
   #:use-module (guix download)
   #:use-module (guix build-system gnu))
 
-(define-public gdb
+(define-public gdb-8.2
   (package
     (name "gdb")
     (version "8.2.1")
@@ -105,3 +105,20 @@ to specify the runtime conditions, to define breakpoints, and to change how
 the program is running to try to fix bugs.  It can be used to debug programs
 written in C, C++, Ada, Objective-C, Pascal and more.")
     (license gpl3+)))
+
+(define-public gdb-8.3
+  (package
+    (inherit gdb-8.2)
+    (version "8.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/gdb/gdb-"
+                                  version ".tar.xz"))
+              (sha256
+               (base32
+                "0bnpzz0rl672xg5547q5qck2sxi6cnyixmk8bbb4gifw17ipwbw0"))))))
+
+(define-public gdb
+  ;; This is the fixed version that packages depend on.  Update it rarely
+  ;; enough to avoid massive rebuilds.
+  gdb-8.2)