summary refs log tree commit diff
path: root/gnu/packages/gdb.scm
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-04-02 20:20:54 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-04-04 12:47:06 +0200
commitb581dd368a0c83d05b97de1c2e0f2443a7c9706f (patch)
treeda386a9129a16a49cafeaa96be7f79eda690e5ff /gnu/packages/gdb.scm
parent39e75fa6929e67ad1424f45923c58a02107f8f22 (diff)
downloadguix-b581dd368a0c83d05b97de1c2e0f2443a7c9706f.tar.gz
gnu: gdb: Make some inputs native.
* gnu/packages/gdb.scm (gdb)[inputs]: Move dejagnu from here...
[native-inputs]: ...to here.

Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu/packages/gdb.scm')
-rw-r--r--gnu/packages/gdb.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 01f93f6def..6331bd23f3 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015, 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -94,7 +95,6 @@
        ("guile" ,guile-2.0)
        ("python" ,python)
        ("python-wrapper" ,python-wrapper)
-       ("dejagnu" ,dejagnu)
        ("source-highlight" ,source-highlight)
 
        ;; Allow use of XML-formatted syscall information.  This enables 'catch
@@ -102,6 +102,7 @@
        ("libxml2" ,libxml2)))
     (native-inputs
       `(("texinfo" ,texinfo)
+        ("dejagnu" ,dejagnu)
         ("pkg-config" ,pkg-config)))
     (home-page "https://www.gnu.org/software/gdb/")
     (synopsis "The GNU debugger")