summary refs log tree commit diff
path: root/gnu/packages/geeqie.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-12-02 12:37:04 +0300
committerAlex Kost <alezost@gmail.com>2016-12-04 17:42:05 +0300
commitd1a5b20081c30da7503201df260cf20b8d0ba633 (patch)
tree4914f643001c2c0317bf597918000650bb419542 /gnu/packages/geeqie.scm
parent023f0fb06ee8dd55f95ff1be542e805363535b97 (diff)
downloadguix-d1a5b20081c30da7503201df260cf20b8d0ba633.tar.gz
gnu: Move image viewers to (gnu packages image-viewers).
* gnu/packages/feh.scm (feh): Remove file.  Move package to...
* gnu/packages/geeqie.scm (geeqie): Likewise...
* gnu/packages/sxiv.scm (sxiv): Likewise...
* gnu/packages/image-viewers.scm: ... here.
* gnu/local.mk (GNU_SYSTEM_MODULES): Remove files.
Diffstat (limited to 'gnu/packages/geeqie.scm')
-rw-r--r--gnu/packages/geeqie.scm75
1 files changed, 0 insertions, 75 deletions
diff --git a/gnu/packages/geeqie.scm b/gnu/packages/geeqie.scm
deleted file mode 100644
index bc922d577a..0000000000
--- a/gnu/packages/geeqie.scm
+++ /dev/null
@@ -1,75 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages geeqie)
-  #:use-module (guix packages)
-  #:use-module (guix download)
-  #:use-module ((guix licenses) #:prefix l:)
-  #:use-module (guix build-system gnu)
-  #:use-module (gnu packages autotools)
-  #:use-module (gnu packages compression)
-  #:use-module (gnu packages ghostscript)
-  #:use-module (gnu packages glib)
-  #:use-module (gnu packages gtk)
-  #:use-module (gnu packages image)
-  #:use-module (gnu packages pkg-config)
-  #:use-module (gnu packages xml))
-
-(define-public geeqie
-  (package
-    (name "geeqie")
-    (version "1.3")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append "https://github.com/BestImageViewer/geeqie/"
-                                 "releases/download/v" version "/geeqie-"
-                                 version ".tar.xz"))
-             (sha256
-              (base32
-               "0gzc82sy66pbsmq7lnmq4y37zqad1zfwfls3ik3dmfm8s5nmcvsb"))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'autogen
-           (lambda _
-             (setenv "NOCONFIGURE" "true")
-             (zero? (system* "sh" "autogen.sh")))))))
-    (inputs
-     `(;; ("libchamplain" ,libchamplain)
-       ("lcms" ,lcms)
-       ("exiv2" ,exiv2)
-       ("libpng" ,libpng)
-       ("gtk+" ,gtk+-2)))
-    (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("glib" ,glib "bin") ; glib-gettextize
-       ("intltool" ,intltool)
-       ("pkg-config" ,pkg-config)))
-    (home-page "http://www.geeqie.org/")
-    (synopsis "Lightweight GTK+ based image viewer")
-    (description
-     "Geeqie is a lightweight GTK+ based image viewer for Unix like operating
-systems.  It features: EXIF, IPTC and XMP metadata browsing and editing
-interoperability; easy integration with other software; geeqie works on files
-and directories, there is no need to import images; fast preview for many raw
-image formats; tools for image comparison, sorting and managing photo
-collection.  Geeqie was initially based on GQview.")
-    (license l:gpl2+)))