summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-11-03 17:02:10 +0100
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-04 19:22:09 +0800
commitdde8ec55b73f423eb6abb8f9a4c62045ca8dc792 (patch)
treed6e6d9a7b1bb7a73d3d96c5aa8afb635cb8b0f6f /gnu/packages/geo.scm
parentdd31f1ab90df3722a7d0b3c18595d021057381f3 (diff)
downloadguix-dde8ec55b73f423eb6abb8f9a4c62045ca8dc792.tar.gz
gnu: shapelib: Update to 1.6.1. [security fixes]
This fixes CVE-2022-0699.

* gnu/packages/geo.scm (shapelib): Update to 1.6.1.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 5d120b3c98..affa50c515 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2574,7 +2574,7 @@ input file (in @code{.osm} or @code{.osm.pbf} format).")
 (define-public shapelib
   (package
     (name "shapelib")
-    (version "1.5.0")
+    (version "1.6.1")
     (source
      (origin
        (method git-fetch)
@@ -2583,7 +2583,7 @@ input file (in @code{.osm} or @code{.osm.pbf} format).")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1lzch0jf6yqhw391phhafzw4ghmiz98zkf698h4fmq109fa2vhqd"))))
+        (base32 "0l67gp1618lcw7fg2iclbh016cqyw85s3cmd3qzx6aw0jq19hj8n"))))
     (build-system gnu-build-system)
     (native-inputs
      (list autoconf automake libtool))
@@ -2591,8 +2591,8 @@ input file (in @code{.osm} or @code{.osm.pbf} format).")
     (synopsis "Provides C library to write and update ESRI Shapefiles")
     (description
      "The Shapefile C Library provides the ability to write simple C programs
-for reading, writing and updating (to a limited extent) ESRI Shapefiles, and the
-associated attribute file (@file{.dbf}).")
+for reading, writing and updating (to a limited extent) ESRI Shapefiles, and
+the associated attribute file (@file{.dbf}).")
     (license license:gpl2+)))
 
 (define-public spatialite-tools