summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-04-03 11:56:20 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-04-03 14:58:43 +0200
commitf4b78c22a1975ef8637c560c6def190abbcc4254 (patch)
tree2f11fa9b847bf1d0b82dc6cdf81dac93646d491e /gnu/packages/geo.scm
parent35351dfd97056974922e59c273fda583a2250ddb (diff)
downloadguix-f4b78c22a1975ef8637c560c6def190abbcc4254.tar.gz
gnu: tippecanoe: Update to 1.36.0.
* gnu/packages/geo.scm (tippecanoe): Update to 1.36.0.
  [arguments]: Use cc-for-target instead of hard-coding gcc.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 37783b7ccd..bc5e6820f3 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1102,7 +1102,7 @@ map, geocoding with Nominatim, or general analysis.")
 (define-public tippecanoe
   (package
     (name "tippecanoe")
-    (version "1.31.5")
+    (version "1.36.0")
     (source
      (origin
        (method git-fetch)
@@ -1111,14 +1111,14 @@ map, geocoding with Nominatim, or general analysis.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1m0x931a945sr7axyhcvpwh798m58hx1zxh6ikgf9gsgqhdhmszz"))))
+        (base32 "0lbmhly4ivnqc6qk1k3sdqvsg6x3nfd8gnjx846bhqj4wag3f88m"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases (delete 'configure))
        #:test-target "test"
        #:make-flags
-       (list "CC=gcc"
+       (list (string-append "CC=" ,(cc-for-target))
              (string-append "PREFIX=" (assoc-ref %outputs "out")))))
     (inputs
      `(("perl" ,perl)