summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-01-23 16:04:26 -0500
committerLeo Famulari <leo@famulari.name>2022-01-25 15:10:19 -0500
commit4235c6ee92b5c8875343c675c8d841eaa9f40d4c (patch)
tree7a70d96653a7abfdbd7fb6a2261ecba323a0837d /gnu/packages/geo.scm
parent676de0a34c7fab3c12e36e0d8349db6ee8da65da (diff)
downloadguix-4235c6ee92b5c8875343c675c8d841eaa9f40d4c.tar.gz
gnu: QGIS: Build without QtWebKit.
See <https://issues.guix.gnu.org/53289> and <https://issues.guix.gnu.org/53512>
for more information about this change.

* gnu/packages/geo.scm (qgis)[inputs]: Remove qtwebkit.
[arguments]: Pass "-DWITH_QTWEBKIT=NO" to #:configure-flags. Make the
custom 'check' phase honor TESTS?. Skip even more failing tests.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 287b157b60..23cec0f9b7 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2274,6 +2274,8 @@ growing set of geoscientific methods.")
        #:imported-modules (,@%cmake-build-system-modules
                            (guix build python-build-system)
                            (guix build qt-utils))
+       #:configure-flags
+       '("-DWITH_QTWEBKIT=NO")
        #:phases
        (modify-phases %standard-phases
          ;; Configure correct path to PyQt5 SIP directory
@@ -2320,7 +2322,8 @@ growing set of geoscientific methods.")
                (("^REV=.*") "REV=currentrev\n"))
              #t))
          (replace 'check
-           (lambda* (#:key inputs #:allow-other-keys)
+           (lambda* (#:key inputs tests? #:allow-other-keys)
+             (when tests?
              (setenv "HOME" "/tmp")
              (system "Xvfb :1 &")
              (setenv "DISPLAY" ":1")
@@ -2400,11 +2403,14 @@ growing set of geoscientific methods.")
                              "qgis_imagecachetest"
                              "qgis_labelingenginetest"
                              "qgis_layouthtmltest"
+                             "qgis_layoutlabeltest"
                              "qgis_layoutmanualtabletest"
                              "qgis_layoutmapgridtest"
                              "qgis_layoutmaptest"
+                             "qgis_layoutmultiframetest"
                              "qgis_layoutpicturetest"
                              "qgis_layouttabletest"
+                             "qgis_layouttest"
                              "qgis_mapdevicepixelratiotest"
                              "qgis_maprendererjobtest"
                              "qgis_ogrproviderguitest"
@@ -2421,7 +2427,7 @@ growing set of geoscientific methods.")
                              "qgis_taskmanagertest"
                              "qgis_wcsprovidertest"
                              "qgis_ziplayertest")
-                           "|"))))
+                           "|")))))
          (add-after 'install 'wrap-python
            (assoc-ref python:%standard-phases 'wrap))
          (add-after 'wrap-python 'wrap-qt
@@ -2490,7 +2496,6 @@ growing set of geoscientific methods.")
            qtlocation
            qtserialport
            qtsvg
-           qtwebkit
            qwt
            ;;("saga" ,saga)
            sqlite))