summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:53:18 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:38 +0200
commit8f33d05e22040c0d00b31b0aed95759cc07fc65e (patch)
tree84c6ff51430bf122cf521cc64fc7057bb7604b71 /gnu/packages/geo.scm
parent82b47fd9d1b8e8fe660812e046388a45036a1cf7 (diff)
downloadguix-8f33d05e22040c0d00b31b0aed95759cc07fc65e.tar.gz
gnu: tippecanoe: Don't use unstable tarball.
* gnu/packages/geo.scm (tippecanoe)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 5d0c5afa73..514ac8f0c4 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -824,14 +824,15 @@ map, geocoding with Nominatim, or general analysis.")
   (package
     (name "tippecanoe")
     (version "1.31.5")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/mapbox/tippecanoe/archive/"
-                                  version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1057na1dkgjaryr7jr15lqkxpam111d3l5zdpdkqzzzpxmdjxqcf"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mapbox/tippecanoe.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1m0x931a945sr7axyhcvpwh798m58hx1zxh6ikgf9gsgqhdhmszz"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases