summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-06 09:20:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-06 09:20:47 +0200
commitb0a7c0c3e1cb881c1ae693d0da32aba315525aab (patch)
tree9ba62000fc0d54b6ed2c0dd30e6a3779afc6157d /gnu/packages/geo.scm
parentc4de60ac3c6aa5b46519011af89988215c347e9e (diff)
downloadguix-b0a7c0c3e1cb881c1ae693d0da32aba315525aab.tar.gz
gnu: gnome-maps: Don't create icon cache.
* gnu/packages/geo.scm (gnome-maps)[arguments]: Add phase to skip
creating the gtk icon cache.
[native-inputs]: Remove gtk+:bin.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index e49e0b6db6..dfb00c7547 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -123,6 +123,12 @@ topology functions.")
      `(#:glib-or-gtk? #t
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'skip-gtk-update-icon-cache
+           ;; Don't create 'icon-theme.cache'.
+           (lambda _
+             (substitute* "meson_post_install.py"
+               (("gtk-update-icon-cache") "true"))
+             #t))
          (add-after 'install 'wrap
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))
@@ -152,8 +158,7 @@ topology functions.")
                                                  ,geocode-glib-path)))
                #t))))))
     (native-inputs
-     `(("gtk+" ,gtk+ "bin") ; gtk-update-icon-cache
-       ("gobject-introspection" ,gobject-introspection)
+     `(("gobject-introspection" ,gobject-introspection)
        ("intltool" ,intltool)
        ("pkg-config" ,pkg-config)))
     (inputs