summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-03-28 10:40:23 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-03-29 11:56:05 +0200
commit46884fc4dfb6647583c22e2c17cf92acf4b13670 (patch)
tree54a75f5a6a94c9f1e90d27174850a47b9e7b6b95 /gnu/packages/geo.scm
parent9bd2478e2ccca3da2edc74670bc4bf878cbb4f70 (diff)
downloadguix-46884fc4dfb6647583c22e2c17cf92acf4b13670.tar.gz
gnu: libgaiagraphics: Remove package.
The libgaiagraphics package was deprecated upstream in 2014 in favor of
librasterlite2 and after the update of spatialite-gui there are no more
packages that depend on it.

* gnu/packages/geo.scm (libgaiagraphics): Remove variable.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index a2f274b379..be05fbe711 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -294,36 +294,6 @@ and driving.")
     (home-page "https://wiki.gnome.org/Apps/Maps")
     (license license:gpl2+)))
 
-(define-public libgaiagraphics
-  (package
-    (name "libgaiagraphics")
-    (version "0.5")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "https://www.gaia-gis.it/gaia-sins/libgaiagraphics-"
-                           version ".tar.gz"))
-       (sha256
-        (base32
-         "076afqv417ag3hfvnif0qc7qscmnq1dsf6y431yygwgf34rjkayc"))))
-    (build-system gnu-build-system)
-    (native-inputs
-     `(("pkg-config" ,pkg-config)))
-    (inputs
-     `(("cairo" ,cairo)
-       ("libpng" ,libpng)
-       ("libjpeg-turbo" ,libjpeg-turbo)
-       ("libtiff" ,libtiff)
-       ("libgeotiff" ,libgeotiff)
-       ("proj.4" ,proj.4)
-       ("libxml2" ,libxml2)
-       ("zlib" ,zlib)))
-     (synopsis "Gaia common graphics support")
-     (description "libgaiagraphics is a library supporting
- common-utility raster handling methods.")
-    (home-page "https://www.gaia-gis.it/fossil/libgaiagraphics/index")
-    (license license:lgpl3+)))
-
 (define-public libgeotiff
   (package
     (name "libgeotiff")