summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2021-02-22 21:15:21 +1100
committerLeo Famulari <leo@famulari.name>2021-04-09 16:09:23 -0400
commitc990604cb044dacf9c52fa33ec63b660329d4cb6 (patch)
tree1dd9368b26702d41063d563d0be5aacc6d7d5984 /gnu/packages/geo.scm
parent073b12d70d069680eda45b87d5a9bde506fe2b7e (diff)
downloadguix-c990604cb044dacf9c52fa33ec63b660329d4cb6.tar.gz
gnu: python-sip: Update to 5.5.0. Add python-sip-4
* gnu/packages/qt.scm (python-sip): Update to 5.5.0.
(python-sip-4): New variable. Rename the old python-sip to python-sip-4.
(python2-sip): Inherit from python-sip-4.
* gnu/packages/maths.scm (veusz)[native-inputs]: Use python-sip-4.
* gnu/packages/pdf.scm (python-poppler-qt5): Use python-sip-4.
* gnu/packages/geo.scm (qgis)[arguments]: Fix build for python-sip@5.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index bc5e6820f3..c4bdb6aca0 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2082,7 +2082,21 @@ growing set of geoscientific methods.")
                (("sip_dir = cfg.default_sip_dir")
                 (string-append "sip_dir = \""
                                (assoc-ref inputs "python-pyqt+qscintilla")
-                               "/share/sip\"")))
+                               "/share/sip\""))
+               ;; Fix building with python-sip@5.
+               ;;
+               ;; The reason for this is that python-sip@5 introduces some
+               ;; changes such as a new build system 'sip-build' as well as the
+               ;; use of the path "/lib/pythonX.X/site-packages/*/bindings/"
+               ;; instead of "/share/sip/" for .sip files. However, we do not
+               ;; actually use that those yet. QGIS detects SIP5 and assumes we
+               ;; are, messing up the build. The long term solution is to fully
+               ;; upgrade SIP, use sip-build and fix all failing packages, but
+               ;; for now I just want to get the build working.
+               ((".pyqt_sip_dir...os.path.join.*,")
+                (string-append "'pyqt_sip_dir': \""
+                               (assoc-ref inputs "python-pyqt+qscintilla")
+                               "/share/sip"  "\",")))
              (substitute* (list "scripts/prepare_commit.sh"
                                 "scripts/qstringfixup.sh"
                                 "scripts/release.pl"