summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-07-03 19:57:26 +0000
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2022-07-08 17:11:23 +0200
commit6f909b37fa12ebf2002c609944b56e0feb77e841 (patch)
tree3c21a43b68e6cd2f9acb85960e2e7e649e8a6816 /gnu/packages/geo.scm
parent15943fa75788edb8d9ed1c3d8d320f50d21e4baa (diff)
downloadguix-6f909b37fa12ebf2002c609944b56e0feb77e841.tar.gz
gnu: gdal: Use cmake-build-system.
Gdal declared its configure script as deprecated with the release of
version 3.5 and is planning to deprecate it with release 3.6 which is
scheduled for November 2022.

* gnu/packages/geo.scm (gdal)[build-system]: Use cmake-build-system.
  [arguments]: Remove configure flags for library search paths;
  they are found automatically by cmake now. Add
  -DGDAL_USE_INTERNAL_LIBS=WHEN_NO_EXTERNAL and
  -DGDAL_USE_JPEG12_INTERNAL=OFF to get approximately the same results
  as with the old configure script.
  [inputs]: Remove pcre. Add pcre2 and qhull.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm26
1 files changed, 5 insertions, 21 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index d8e642f349..c934ee9e27 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -969,29 +969,12 @@ development.")
                        "frmts/gtiff/libgeotiff"
                        "frmts/zlib"
                        "ogr/ogrsf_frmts/geojson/libjson"))))))
-    (build-system gnu-build-system)
+    (build-system cmake-build-system)
     (arguments
      `(#:tests? #f
        #:configure-flags
-       (let-syntax ((with (syntax-rules ()
-                            ((_ option input)
-                             (string-append option "="
-                                            (assoc-ref %build-inputs input))))))
-         (list
-          ;; TODO: --with-pcidsk, --with-pcraster
-          (with "--with-expat" "expat")
-          (with "--with-freexl" "freexl")
-          (with "--with-geotiff" "libgeotiff")
-          (with "--with-gif" "giflib")
-          (with "--with-jpeg" "libjpeg-turbo")
-          (with "--with-libjson-c" "json-c")
-          (with "--with-libtiff" "libtiff")
-          (with "--with-libz" "zlib")
-          (with "--with-png" "libpng")
-          (with "--with-sqlite3" "sqlite")
-          (with "--with-webp" "libwebp")
-          "--without-jpeg12"
-          "--with-pcre"))))
+       (list "-DGDAL_USE_INTERNAL_LIBS=WHEN_NO_EXTERNAL"
+             "-DGDAL_USE_JPEG12_INTERNAL=OFF")))
     (inputs
      (list curl
            expat
@@ -1006,9 +989,10 @@ development.")
            libwebp
            netcdf
            openssl
-           pcre
+           pcre2
            postgresql ; libpq
            proj
+           qhull
            sqlite
            zlib))
     (native-inputs