summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-09-08 20:14:35 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2022-09-11 15:50:48 +0200
commit8bb5bcf679dd34c390959c52c61b6567f7873073 (patch)
treedfc5159c33d8ac800c8f80b240600a5d40b7d265 /gnu/packages/geo.scm
parentb7376b310a5a6a199aec31fada36a22367c3e32f (diff)
downloadguix-8bb5bcf679dd34c390959c52c61b6567f7873073.tar.gz
gnu: python-cartopy: Update to 0.20.3.
* gnu/packages/geo.scm (python-cartopy): Update to 0.20.3.
  [propagated-inputs]: Add python-pyproj.
  [inputs]: Add comment to explain why proj is needed after depending on
  python-pyproj.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 98a9e05b9b..f27c97477d 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1088,13 +1088,13 @@ utilities for data translation and processing.")
   (package
     (name "python-cartopy")
     ;; This is a post-release fix that adds build_ext to setup.py.
-    (version "0.19.0.post1")
+    (version "0.20.3")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Cartopy" version))
        (sha256
-        (base32 "0xnm8z3as3hriivdfd26s6vn5b63gb46x6vxw6gh1mwfm5rlg2sb"))))
+        (base32 "01lhnkhw22jp6hnrs5qvgkq4fqcni2sx7ydiyv8w8xxx5wpglq0d"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -1112,11 +1112,16 @@ utilities for data translation and processing.")
      (list python-matplotlib
            python-numpy
            python-pykdtree
+           python-pyproj
            python-pyshp
            python-scipy
            python-shapely))
     (inputs
-     (list geos proj))
+     (list geos
+           ;; cartopy's setup.py looks for the proj executable.
+           ;; Not sure if it actually makes use of it since it
+           ;; probably uses proj only through pyproj.
+           proj))
     (native-inputs
      (list python-cython python-flufl-lock python-pytest))
     (home-page "https://scitools.org.uk/cartopy/docs/latest/")