summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-24 19:37:07 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:25 +0000
commitd0b091221240e81b2a781ed8b2539d827343fe04 (patch)
treec9dd2fe374c95246accae781ef343dfc94f24a7f /gnu/packages/geo.scm
parent821fa7bd4389c1f830d6d83564107a242db03129 (diff)
downloadguix-d0b091221240e81b2a781ed8b2539d827343fe04.tar.gz
gnu: gnome-maps: Update to 40.5.
* gnu/packages/geo.scm (gnome-maps): Update to 40.5.
[source]: Fix the URI.
[arguments]: Remove trailing #t.
[inputs]: Add libhandy.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 0be0703b82..12108f682b 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -211,15 +211,15 @@ topology functions.")
 (define-public gnome-maps
   (package
     (name "gnome-maps")
-    (version "3.38.5")
+    (version "40.5")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
-                                  (version-major+minor version) "/"
+                                  (version-major version) "/"
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1llgzm2ni3iy31dznqkc81vadv0fpqgpz2l9zzrj5jshvyq0akgh"))))
+                "02bdkmb3wyzfrbq726634v4g1hyh9za70cc2ivlbp7zc2n1jgp5c"))))
     (build-system meson-build-system)
     (arguments
      `(#:glib-or-gtk? #t
@@ -229,14 +229,13 @@ topology functions.")
            ;; Don't create 'icon-theme.cache'.
            (lambda _
              (substitute* "meson_post_install.py"
-               (("gtk-update-icon-cache") "true"))
-             #t))
+               (("gtk-update-icon-cache") "true"))))
          (add-after 'unpack 'patch-dbus-service
            (lambda* (#:key outputs #:allow-other-keys)
              (substitute* "data/org.gnome.Maps.service.in"
                (("@pkgdatadir@/org.gnome.Maps")
-                (string-append  (assoc-ref outputs "out") "/bin/gnome-maps")))
-             #t))
+                (string-append  (assoc-ref outputs "out")
+                                "/bin/gnome-maps")))))
          (add-after 'install 'wrap
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))
@@ -274,6 +273,7 @@ topology functions.")
        ("folks" ,folks)
        ("libchamplain" ,libchamplain)
        ("libgee" ,libgee)
+       ("libhandy" ,libhandy)
        ("libsecret" ,libsecret)
        ("libsoup" ,libsoup)
        ("libgweather" ,libgweather)