summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-05-18 19:21:11 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-21 00:15:09 +0200
commit09d0d0f6a5280200d15f2d102c963a712c681b14 (patch)
treec476d2d11bc9eaef2c1a61069ef2daa1cd7efc7f /gnu/packages/geo.scm
parent4df064f37ae3934e8f5a0672ea3f54b8f1130cde (diff)
downloadguix-09d0d0f6a5280200d15f2d102c963a712c681b14.tar.gz
gnu: python-geopandas: Fix build.
* gnu/packages/geo.scm (python-geopandas)[arguments]: Disable broken
  tests. Re-enable test_fillna_no_op_returns_copy which does not fail
  anymore.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index c2569c27d4..0c9240eea7 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -715,9 +715,14 @@ pyproj, Rtree, and Shapely.")
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
                (invoke "pytest"
-                       ; Disable test that fails with
-                       ; NotImplementedError in pandas.
-                       "-k" "not test_fillna_no_op_returns_copy"
+                       ; Disable tests that fail due to incompatibilities
+                       ; with our pandas version.
+                       "-k"
+                       (string-append
+                         "not test_getitem_invalid"
+                         " and not test_value_counts"
+                         " and not test_setitem_invalid"
+                         " and not test_insert_invalid")
                        ; Disable tests that require internet access.
                        "-m" "not web")))))))
     (propagated-inputs