summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-11-27 13:21:51 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-11-27 14:27:23 +0100
commite2f01318af008b7d0a2a02b914ab7e2e80bbce0b (patch)
treebbc299220c4999e6053c24e233c528910b82a9cd /gnu/packages/geo.scm
parentaad44e9484cc5c7cef3bdae7e889b7013dfa7700 (diff)
downloadguix-e2f01318af008b7d0a2a02b914ab7e2e80bbce0b.tar.gz
gnu: marble-qt: Move to (gnu packages kde).
* gnu/packages/geo.scm (marble-qt): Move to (gnu packages kde).

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm40
1 files changed, 0 insertions, 40 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 6362300d6c..19618ab731 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2594,46 +2594,6 @@ coordinates of addresses, cities, countries, and landmarks across the globe
 using third-party geocoders and other data sources.")
     (license license:expat)))
 
-(define-public marble-qt
-  (let ((release "17.08")
-        (commit "fc7166eeef784732033c999ba605364f9c82d21c")
-        (revision "1"))
-    (package
-      (name "marble-qt")
-      (version (git-version release revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://invent.kde.org/education/marble.git/")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "0m0sf3sddaib7vc5lhbmh7ziw07p1hahg02f65sgfylyl5f5kj92"))
-         (patches (search-patches
-                   "marble-qt-add-qt-headers.patch"))))
-      (build-system cmake-build-system)
-      (arguments
-       `(#:tests? #f ; libmarblewidget-qt5.so.28 not found
-         #:configure-flags
-         '("-DCMAKE_BUILD_TYPE=Release"
-           "-DWITH_KF5=FALSE")))
-      (native-inputs
-       `(("qttools" ,qttools)))
-      (inputs
-       `(("qtbase" ,qtbase-5)
-         ("qtsvg" ,qtsvg)
-         ("qtdeclarative" ,qtdeclarative)
-         ("qtwebkit" ,qtwebkit)
-         ("qtlocation" ,qtlocation)))
-      (home-page "https://marble.kde.org/")
-      (synopsis "Virtual globe and world atlas")
-      (description "Marble is similar to a desktop globe.  At closer scale it
-becomes a world atlas, while OpenStreetMap takes the user to street level.  It
-supports searching for places of interest, viewing Wikipedia articles,
-creating routes by drag and drop and more.")
-      (license license:gpl3))))
-
 (define-public gplates
   (package
     (name "gplates")