summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorNikolay Korotkiy <sikmir@gmail.com>2022-02-08 12:00:48 +0300
committerLudovic Courtès <ludo@gnu.org>2022-03-09 23:38:18 +0100
commiteeac33a3defec89fcc5d417844fd4ce67b41ba0e (patch)
tree72e6d4c4ef63af68def79c211b35e5b320857118 /gnu/packages/geo.scm
parent30daa0d9728e39f13a49991fe77fc46c9aa889ab (diff)
downloadguix-eeac33a3defec89fcc5d417844fd4ce67b41ba0e.tar.gz
gnu: Add osmium-tool.
* gnu/packages/geo.scm (osmium-tool): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 82e1ef73f7..6b3448a261 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -82,6 +82,7 @@
   #:use-module (gnu packages graphics)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages haskell-apps)
+  #:use-module (gnu packages haskell-xyz)
   #:use-module (gnu packages image)
   #:use-module (gnu packages image-processing)
   #:use-module (gnu packages icu4c)
@@ -1209,6 +1210,35 @@ to create databases that are optimized for rendering/tile/map-services.")
 OpenStreetMap data.")
     (license license:boost1.0)))
 
+(define-public osmium-tool
+  (package
+    (name "osmium-tool")
+    (version "1.14.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/osmcode/osmium-tool")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0zgyqyrs89vch0qnkh9m5xq079sr2wmydy5zz4l8xbysbjf6xry5"))
+       (modules '((guix build utils)))
+       (snippet
+        ;; Remove bundled libraries.
+        '(delete-file-recursively "include/rapidjson"))))
+    (build-system cmake-build-system)
+    (inputs
+     (list libosmium
+           rapidjson))
+    (native-inputs
+     (list pandoc))
+    (home-page "https://osmcode.org/osmium-tool/")
+    (synopsis "Osmium command-line tool")
+    (description "Command line tool for working with OpenStreetMap data
+based on the Osmium library.")
+    (license license:gpl3+)))
+
 (define-public osm2pgsql
   (package
     (name "osm2pgsql")