summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-17 12:40:28 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:29 -0500
commit41ec0573b81733e15b70312d81cf7fdf77dd63fe (patch)
tree4e95786550ac717bbebc24c7b5f4e3c46ecd1825 /gnu/packages/geo.scm
parent6f36d0c89e3bf19bb7bb8f7f5b77de30c9af861b (diff)
downloadguix-41ec0573b81733e15b70312d81cf7fdf77dd63fe.tar.gz
gnu: Remove meson-0.59 workarounds.
Mostly automated with the following command:

$ grep --include='*.scm' '#:meson ,meson-0.59' -rl \
    | xargs sed -z 's/#:meson[^\n]*\s*//' -i

* gnu/packages/freedesktop.scm (malcontent)
(accountsservice): Delete #:meson argument.
* gnu/packages/games.scm (gnome-2048): Likewise.
* gnu/packages/geo.scm (gnome-maps): Likewise.
* gnu/packages/gnome.scm (gnome-photos, gnome-music)
(gnome-initial-setup, gnome-user-share, gnome-characters)
(gnome-disk-utility, gnome-font-viewer, evince, glade3)
(gnome-mines, gnome-sudoku, gnome-settings-daemon, devhelp)
(totem, eog, gvfs, simple-scan, epiphany, gnome-session, gedit)
(network-manager-applet, gnome-control-center, gnome-shell, nautilus)
(gnome-default-applications, gnome-weather, gnome-tweaks, cheese, gthumb)
(gitg, polari, gnome-boxes, gtranslator): Likewise.
* gnu/packages/gtk.scm: (gtkmm-3): Likewise.
* gnu/packages/pdf.scm (zathura): Likewise.
* gnu/packages/photo.scm (entangle): Likewise.
* gnu/packages/video.scm (pitivi): Likewise.
* gnu/packages/virtualization.scm (libvirt-glib): Likewise.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 8e5965c97c..0f965b120d 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -229,8 +229,7 @@ topology functions.")
                 "037xmkmcmcw87vb1c1s3y225m8757k331cvk1m8cshf6mx61p0l1"))))
     (build-system meson-build-system)
     (arguments
-     `(#:meson ,meson-0.59         ;positional arguments error with meson 0.60
-       #:glib-or-gtk? #t
+     `(#:glib-or-gtk? #t
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'skip-gtk-update-icon-cache