summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorGuillaume LE VAILLANT <glv@posteo.net>2019-06-14 19:27:50 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-26 15:59:58 +0200
commitee34be7375c3ce348478b0eca7822a63b24621c2 (patch)
treea07e231332043035378a9db1925b8cb6555cb444 /gnu/packages/geo.scm
parentf825e60590be9c8215d345f72031abeb855b1a85 (diff)
downloadguix-ee34be7375c3ce348478b0eca7822a63b24621c2.tar.gz
gnu: Add osm-gps-map
* gnu/packages/geo.scm (osm-gps-map): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index ec5ace3519..4cccd97643 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -869,3 +869,36 @@ dropping features at lower levels.")
 OpenStreetMap project.  They can be used to convert, filter and update
 OpenStreetMap data files.")
     (license license:agpl3)))
+
+(define-public osm-gps-map
+  (package
+    (name "osm-gps-map")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/nzjrs/osm-gps-map/releases/download/"
+             version "/osm-gps-map-" version ".tar.gz"))
+       (sha256
+        (base32
+         "11imsf4cz1dpxdjh178k2s29axmq86rkfg1pqmn7incyxmjzhbwg"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("gnome-common" ,gnome-common)
+       ("gtk-doc" ,gtk-doc)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("cairo" ,cairo)
+       ("glib" ,glib)
+       ("gobject-introspection" ,gobject-introspection)
+       ("gtk+" ,gtk+)
+       ("libsoup" ,libsoup)))
+    (home-page "https://nzjrs.github.io/osm-gps-map/")
+    (synopsis "GTK+ widget for displaying OpenStreetMap tiles")
+    (description
+     "This package provides a GTK+ widget (and Python bindings) that when
+given GPS coordinates,draws a GPS track, and points of interest on a moving
+map display.  Downloads map data from a number of websites, including
+@url{https://www.openstreetmap.org}.")
+    (license license:gpl2+)))