summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2020-05-11 13:30:44 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2020-12-29 13:54:49 +0100
commita2d5f9f60d0f440e5d5ce1a1cc81743b27d6cede (patch)
tree4fdd467121fb8bab40e8e1b8892e2fcaffef4def /gnu/packages/geo.scm
parente5c258b65a3051b0962b2cff74b011b731efac83 (diff)
downloadguix-a2d5f9f60d0f440e5d5ce1a1cc81743b27d6cede.tar.gz
gnu: gnome-maps: Patch DBUS service.
* gnu/packages/geo.scm (gnome-maps):
[arguments]<#:phases>: Add patch-dbus-service.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index b8daf323e9..f7f18cf79f 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -227,6 +227,12 @@ topology functions.")
              (substitute* "meson_post_install.py"
                (("gtk-update-icon-cache") "true"))
              #t))
+         (add-after 'unpack 'patch-dbus-service
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* "data/org.gnome.Maps.service.in"
+               (("@pkgdatadir@/org.gnome.Maps")
+                (string-append  (assoc-ref outputs "out") "/bin/gnome-maps")))
+             #t))
          (add-after 'install 'wrap
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))