summary refs log tree commit diff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-10-05 11:58:16 +0200
committerJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-10-05 12:01:47 +0200
commit2fc298d19c5256eb5609aae7bd35bada59d91685 (patch)
tree1972da8a883fe4f6e3bd4a753e07f2022636c5e8 /gnu/packages/gettext.scm
parent599954c1377a4fc8936f7f341a678ecb9579a2c6 (diff)
downloadguix-2fc298d19c5256eb5609aae7bd35bada59d91685.tar.gz
gnu: gettext-minimal: Mark "test-raise" test XFAIL on the Hurd.
* gnu/packages/gettext.scm (gettext-minimal)[arguments]: When compiling for
the Hurd, add "test-raise" to XFAIL_TESTS in make-flags.
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index b9070ae818..426be35a25 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -9,6 +9,7 @@
 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Miguel <rosen644835@gmail.com>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -34,6 +35,7 @@
   #:use-module (guix build-system perl)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages emacs)
+  #:use-module (gnu packages hurd)
   #:use-module (gnu packages libunistring)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages perl)
@@ -106,7 +108,11 @@
                #t)))))
 
        ;; When tests fail, we want to know the details.
-       #:make-flags '("VERBOSE=yes")))
+       #:make-flags '("VERBOSE=yes"
+                      ,@(if (hurd-target?)
+                            ;; Linking to libgettextlib.so makes test-raise fail
+                            '("XFAIL_TESTS=test-raise")
+                            '()))))
     (home-page "https://www.gnu.org/software/gettext/")
     (synopsis
      "Tools and documentation for translation (used to build other packages)")