summary refs log tree commit diff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-30 11:33:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-30 12:39:40 +0200
commit4cf1acc7f3033b50b0bf19e02c9f522d522d338c (patch)
tree9fd64956ee60304c15387eb394cd649e49f01467 /gnu/packages/gettext.scm
parentedb8c09addd186d9538d43b12af74d6c7aeea082 (diff)
parent595b53b74e3ef57a1c0c96108ba86d38a170a241 (diff)
downloadguix-4cf1acc7f3033b50b0bf19e02c9f522d522d338c.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
 Conflicts:
	doc/guix.texi
	gnu/local.mk
	gnu/packages/admin.scm
	gnu/packages/base.scm
	gnu/packages/chromium.scm
	gnu/packages/compression.scm
	gnu/packages/databases.scm
	gnu/packages/diffoscope.scm
	gnu/packages/freedesktop.scm
	gnu/packages/gnome.scm
	gnu/packages/gnupg.scm
	gnu/packages/guile.scm
	gnu/packages/inkscape.scm
	gnu/packages/llvm.scm
	gnu/packages/openldap.scm
	gnu/packages/pciutils.scm
	gnu/packages/ruby.scm
	gnu/packages/samba.scm
	gnu/packages/sqlite.scm
	gnu/packages/statistics.scm
	gnu/packages/syndication.scm
	gnu/packages/tex.scm
	gnu/packages/tls.scm
	gnu/packages/version-control.scm
	gnu/packages/xml.scm
	guix/build-system/copy.scm
	guix/scripts/home.scm
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm59
1 files changed, 37 insertions, 22 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index bf4c98e36c..0cc424acae 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -11,6 +11,7 @@
 ;;; Copyright © 2019 Miguel <rosen644835@gmail.com>
 ;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2020 EuAndreh <eu@euandre.org>
+;;; Copyright © 2022 gemmaro <gemmaro.dev@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,6 +37,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system python)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages check)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages emacs)
@@ -121,13 +123,19 @@
                                                "coreutils-gnulib-tests.patch")))))
                               '())
 
+                       #$@(if (hurd-target?)
+                              #~((substitute*
+                                     "gettext-tools/gnulib-tests/Makefile.in"
+                                   ;; See 'coreutils' for the rationale.
+                                   ((" test-tls\\$\\(EXEEXT\\) ") " ")))
+                              '())
+
                        #t)))))
 
        ;; When tests fail, we want to know the details.
        #:make-flags #~'("VERBOSE=yes"
                         #$@(if (hurd-target?)
-                               ;; Linking to libgettextlib.so makes test-raise fail
-                               '("XFAIL_TESTS=test-raise")
+                               '("XFAIL_TESTS=test-perror2")
                                '()))))
     (home-page "https://www.gnu.org/software/gettext/")
     (synopsis
@@ -234,14 +242,14 @@ from Markdown files.")
 (define-public po4a
   (package
     (name "po4a")
-    (version "0.63")
+    (version "0.68")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/mquinson/po4a/releases/download/v"
                                   version "/po4a-" version ".tar.gz"))
               (sha256
                (base32
-                "1kmlfpdl1i1wrcdn0k1frh44fq10sfwswi3azvibli2lakpf66z2"))))
+                "045i8izp2dqmkdzvnxyy5sy27ffrwl85dk8n6cmg1804ikk28qdg"))))
     (build-system perl-build-system)
     (arguments
      `(#:phases
@@ -252,9 +260,21 @@ from Markdown files.")
             ;; required by this package at runtime.
             (let* ((out  (assoc-ref outputs "out"))
                    (bin  (string-append out "/bin/"))
-                   (Pod::Parser (assoc-ref inputs "perl-pod-parser"))
                    (path (string-append out "/lib/perl5/site_perl:"
-                                        Pod::Parser "/lib/perl5/site_perl")))
+                                        (string-join
+                                         (map (lambda (name)
+                                                (string-append (assoc-ref inputs name)
+                                                               "/lib/perl5/site_perl"))
+                                              (list "perl-gettext"
+                                                    "perl-pod-parser"
+                                                    "perl-sgmls"
+                                                    "perl-syntax-keyword-try"
+                                                    "perl-xs-parse-keyword"
+                                                    "perl-term-readkey"
+                                                    "perl-text-wrapi18n"
+                                                    "perl-unicode-linebreak"
+                                                    "perl-yaml-tiny"))
+                                         ":"))))
               (for-each (lambda (file)
                           (wrap-program file
                             `("PERL5LIB" ":" prefix (,path))))
@@ -267,23 +287,10 @@ from Markdown files.")
                 (string-append (assoc-ref inputs "docbook-xml")
                                "/xml/dtd/docbook/")))
              #t))
-         (add-before 'build 'do-not-override-PERL5LIB
-           (lambda _
-             ;; Don't hard-code PERL5LIB to include just the build directory
-             ;; so that the build script finds modules from inputs.
-             (substitute* "Po4aBuilder.pm"
-               (("PERL5LIB=lib") ""))
-             (setenv "PERL5LIB" (string-append (getenv "PERL5LIB") ":lib"))))
          (add-before 'check 'disable-failing-tests
            (lambda _
-             ;; FIXME: these tests require SGMLS.pm.
-             (delete-file "t/01-classes.t")
-
-             (delete-file "t/add.t")
-             (delete-file "t/core-porefs.t")
-             (delete-file "t/fmt-asciidoc.t")
+             ;; FIXME: fails despite of importing SGMLS
              (delete-file "t/fmt-sgml.t")
-
              #t)))))
     (native-inputs
      `(("gettext" ,gettext-minimal)
@@ -295,10 +302,18 @@ from Markdown files.")
        ;; For tests.
        ("docbook-xml" ,docbook-xml-4.1.2)
        ("perl-test-pod" ,perl-test-pod)
-       ("perl-yaml-tiny" ,perl-yaml-tiny)
        ("texlive" ,texlive-tiny)))
     (inputs
-     (list perl-pod-parser))
+     (list bash-minimal
+           perl-gettext
+           perl-pod-parser
+           perl-sgmls
+           perl-syntax-keyword-try
+           perl-xs-parse-keyword
+           perl-term-readkey
+           perl-text-wrapi18n
+           perl-unicode-linebreak
+           perl-yaml-tiny))
     (home-page "https://po4a.org/")
     (synopsis "Scripts to ease maintenance of translations")
     (description