summary refs log tree commit diff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-05-25 16:19:06 +0200
committerLudovic Courtès <ludo@gnu.org>2013-05-25 16:19:06 +0200
commit2a552f1177fc79a66ba5ae53467556dfa3386b68 (patch)
treef3cd020fc101c848f630e5325e845ac688b101ae /gnu/packages/gettext.scm
parenta7dc055bb5e07e716e929f8a906081fbe0422ad3 (diff)
downloadguix-2a552f1177fc79a66ba5ae53467556dfa3386b68.tar.gz
gnu: gettext, attr, acl: Disable `check' phase twiddling when cross building.
* gnu/packages/gettext.scm (gettext)[arguments]: Disable `check' phase
  manipulations when (%current-target-system) is true.
* gnu/packages/attr.scm (attr)[arguments]: Likewise.
* gnu/packages/acl.scm (acl)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm29
1 files changed, 16 insertions, 13 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 29ea54924a..e22b1ba6ff 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -38,19 +38,22 @@
     (build-system gnu-build-system)
     (arguments
      `(#:patches (list (assoc-ref %build-inputs "patch/gets"))
-       #:phases (alist-cons-before
-                 'check 'patch-tests
-                 (lambda* (#:key inputs #:allow-other-keys)
-                   (let ((bash (assoc-ref inputs "bash")))
-                     (substitute* (find-files "gettext-tools/tests"
-                                              "^msgexec-[0-9]")
-                       (("#![[:blank:]]/bin/sh")
-                        (format #f "#!~a/bin/sh" bash)))
-                     (substitute* (find-files "gettext-tools/gnulib-tests"
-                                              "posix_spawn")
-                       (("/bin/sh")
-                        (format #f "~a/bin/bash" bash)))))
-                 %standard-phases)))
+       #:phases ,(if (%current-target-system)
+                     '%standard-cross-phases
+                     '(alist-cons-before
+                       'check 'patch-tests
+                       (lambda* (#:key inputs #:allow-other-keys)
+                         ;; TODO: Use (which "sh").
+                         (let ((bash (assoc-ref inputs "bash")))
+                           (substitute* (find-files "gettext-tools/tests"
+                                                    "^msgexec-[0-9]")
+                             (("#![[:blank:]]/bin/sh")
+                              (format #f "#!~a/bin/sh" bash)))
+                           (substitute* (find-files "gettext-tools/gnulib-tests"
+                                                    "posix_spawn")
+                             (("/bin/sh")
+                              (format #f "~a/bin/bash" bash)))))
+                       %standard-phases))))
     (inputs
      `(("patch/gets"
         ,(search-patch "gettext-gets-undeclared.patch"))))