summary refs log tree commit diff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 02:23:16 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:41:59 -0400
commitae7ba7312448fd13532d25df37db225559573055 (patch)
treefe2ac2548f85bac3a2a1b045ba94d7b02c4a0143 /gnu/packages/gettext.scm
parente3eb53e7492f8dbbb52c34511c2effc1af82e020 (diff)
downloadguix-ae7ba7312448fd13532d25df37db225559573055.tar.gz
gnu: gettext-minimal: Return #t from all phases.
* gnu/packages/gettext.scm (gettext-minimal)[arguments]: Return #t from
the 'patch-tests' and 'link-expat' phases.
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index f14ca27810..9b45e84559 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -89,14 +89,17 @@
 
                (substitute* "gettext-tools/src/project-id"
                  (("/bin/pwd")
-                  "pwd"))))))
+                  "pwd"))
+
+               #t))))
         (add-before 'configure 'link-expat
          (lambda _
            ;; Gettext defaults to opening expat via dlopen on
            ;; "Linux".  Change to link directly.
            (substitute* "gettext-tools/configure"
              (("LIBEXPAT=\"-ldl\"") "LIBEXPAT=\"-ldl -lexpat\"")
-             (("LTLIBEXPAT=\"-ldl\"") "LTLIBEXPAT=\"-ldl -lexpat\"")))))
+             (("LTLIBEXPAT=\"-ldl\"") "LTLIBEXPAT=\"-ldl -lexpat\""))
+           #t)))
 
        ;; When tests fail, we want to know the details.
        #:make-flags '("VERBOSE=yes")))