summary refs log tree commit diff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 02:25:19 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:42:02 -0400
commiteb075eddfcbe17b73f3bce9e932c234e50aad3a5 (patch)
tree3a00e40a002cfa6c15405c87d53c7db9883d63b0 /gnu/packages/ghostscript.scm
parentae7ba7312448fd13532d25df37db225559573055 (diff)
downloadguix-eb075eddfcbe17b73f3bce9e932c234e50aad3a5.tar.gz
gnu: ghostscript: Use invoke.
* gnu/packages/ghostscript.scm (ghostscript): Use invoke from the
custom 'build' and 'install' phases.
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 6bbedffa2c..9a02c47f45 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -214,11 +214,11 @@ printing, and psresize, for adjusting page sizes.")
            (lambda _
              ;; Build 'libgs.so', but don't build the statically-linked 'gs'
              ;; binary (saves 22 MiB).
-             (zero? (system* "make" "so" "-j"
-                             (number->string (parallel-job-count))))))
+             (invoke "make" "so" "-j"
+                     (number->string (parallel-job-count)))))
          (replace 'install
            (lambda _
-             (zero? (system* "make" "soinstall"))))
+             (invoke "make" "soinstall")))
          (add-after 'install 'create-gs-symlink
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))