summary refs log tree commit diff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-05-06 23:50:30 +0200
committerLudovic Courtès <ludo@gnu.org>2013-05-06 23:50:30 +0200
commit6d267f0a5b745f282757c29af26c571f590b4144 (patch)
tree8d79c091510811d12ac4458b54955208cff9d7e9 /gnu/packages/ghostscript.scm
parent36ee486f1ad1c13f394c993e6130180fdc7366c9 (diff)
downloadguix-6d267f0a5b745f282757c29af26c571f590b4144.tar.gz
gnu: gv: Move to a separate file.
* gnu/packages/ghostscript.scm (ghostscript): Remove libxext and libxt
  as inputs.
  (gv): Move to...
* gnu/packages/gv.scm (gv): ... here.  New file.
  (ghostscript/x): Variant of GHOSTSCRIPT with libxt and libxext as
  inputs.
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 6781ffecdf..04aac9d94e 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -27,7 +27,6 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages tcl)
-  #:use-module (gnu packages xorg)
   #:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:))
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -135,8 +134,6 @@ printing, and psresize, for adjusting page sizes.")
              ("libpng" ,libpng)
              ("libpaper" ,libpaper)
              ("libtiff" ,libtiff)
-             ("libxext" ,libxext)
-             ("libxt" ,libxt)
              ("perl" ,perl)
              ("pkg-config" ,pkg-config) ; needed to find libtiff
              ("python" ,python)
@@ -217,28 +214,3 @@ Ghostscript. It currently includes the 35 standard PostScript fonts.")
    (license license:gpl2)
    (home-page "http://sourceforge.net/projects/gs-fonts/")))
 
-(define-public gv
-  (package
-   (name "gv")
-   (version "3.7.4")
-   (source (origin
-            (method url-fetch)
-            (uri (string-append "mirror://gnu/gv/gv-"
-                                version ".tar.gz"))
-            (sha256 (base32
-                     "0q8s43z14vxm41pfa8s5h9kyyzk1fkwjhkiwbf2x70alm6rv6qi1"))))
-   (build-system gnu-build-system)
-   (propagated-inputs `(("ghostscript" ,ghostscript)))
-   (inputs `(("libx11" ,libx11)
-             ("libxaw3d" ,libxaw3d)
-             ("libxinerama" ,libxinerama)
-             ("libxpm" ,libxpm)
-             ("pkg-config" ,pkg-config)
-             ("zlib" ,zlib)))
-   (synopsis "postscript and pdf viewer for x")
-   (description
-    "GNU gv allows to view and navigate through PostScript and PDF documents
-on an X display by providing a graphical user interface for the Ghostscript
-interpreter.")
-   (license license:gpl3+)
-   (home-page "http://www.gnu.org/software/gv/")))