summary refs log tree commit diff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-01-03 12:01:38 -0500
committerLeo Famulari <leo@famulari.name>2023-01-03 12:07:46 -0500
commit4c123214669a9c54173cd89e0f86b603b23d93ea (patch)
tree9aae7a87da9f572dfbed34f19b26a1a0a75d04da /gnu/packages/gimp.scm
parentcfce55bf4f232791f4341665a01c4cb873f0f60d (diff)
downloadguix-4c123214669a9c54173cd89e0f86b603b23d93ea.tar.gz
gnu: Remove Glimpse.
This package no longer builds and is abandoned upstream:

https://glimpse-editor.org/posts/a-project-on-hiatus/

* gnu/packages/gimp.scm (gegl-for-glimpse, glimpse): Remove variables.
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm96
1 files changed, 1 insertions, 95 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 8de98b7eba..beb43f0ae2 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -3,7 +3,7 @@
 ;;; Copyright © 2016, 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017, 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018, 2020 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
@@ -550,97 +550,3 @@ tools for healing selections (content-aware fill), enlarging the canvas and
 healing the border, increasing the resolution while adding detail, and
 transferring the style of an image.")
     (license license:gpl3+)))
-
-(define gegl-for-glimpse
-  ;; Remove this when GIMP commit 2cae9b9acf9da98c4c9990819ffbd5aabe23017e
-  ;; makes it into Glimpse.
-  (package
-    (inherit gegl)
-    (arguments
-     (substitute-keyword-arguments (package-arguments gegl)
-       ((#:phases phases)
-        `(modify-phases ,phases
-           (add-after 'unpack 'refer-to-dot
-             ;; XXX Without ‘dot’ in $PATH, Glimpse would fail to start with an
-             ;; extremely obtuse ‘GEGL operation missing!’ error.
-             (lambda _
-               (substitute* "gegl/gegl-dot.c"
-                 (("\"dot ")
-                  (format #f "\"~a " (which "dot"))))
-               (substitute* "operations/common/introspect.c"
-                 (("g_find_program_in_path \\(\"dot\"\\)")
-                  (format #f "g_strdup (\"~a\")" (which "dot"))))))))))
-    (inputs
-     `(,@(package-inputs gegl)
-       ("graphviz" ,graphviz)))))
-
-(define-public glimpse
-  (package
-    (name "glimpse")
-    (version "0.2.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/glimpse-editor/Glimpse")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0drngj2xqzxfaag6pc4xjffiw003n4y43x5rb5bf4ziv1ac51dm9"))))
-    (build-system gnu-build-system)
-    (outputs '("out"
-               "doc"))                  ; 9 MiB of gtk-doc HTML
-    (arguments
-     (list
-      #:configure-flags
-      #~(list
-         (string-append "--with-html-dir=" #$output "/share/gtk-doc/html")
-         "--enable-gtk-doc"
-
-         ;; Prevent the build system from running 'gtk-update-icon-cache'
-         ;; which is not needed during the build because Guix runs it at
-         ;; profile creation time.
-         "ac_cv_path_GTK_UPDATE_ICON_CACHE=true"
-
-         ;; Disable automatic network request on startup to check for
-         ;; version updates.
-         "--disable-check-update"
-
-         ;; ./configure requests not to annoy upstream with packaging bugs.
-         "--with-bug-report-url=https://bugs.gnu.org/guix")))
-    (native-inputs
-     (list autoconf
-           automake
-           gtk-doc
-           intltool
-           libtool
-           libxslt                      ;for xsltproc
-           pkg-config
-           `(,glib "bin")))             ;for gdbus-codegen
-    (inputs
-     (list babl
-           glib
-           glib-networking
-           libtiff
-           libwebp
-           libjpeg-turbo
-           atk
-           gexiv2
-           gtk+-2
-           libmypaint
-           mypaint-brushes-1.3
-           libexif                      ;optional, EXIF + XMP support
-           lcms                         ;optional, color management
-           librsvg                      ;optional, SVG support
-           libxcursor                   ;optional, Mouse Cursor support
-           poppler                      ;optional, PDF support
-           poppler-data
-           gegl-for-glimpse))           ;XXX see comment in gegl-for-glimpse
-    (home-page "https://glimpse-editor.github.io/")
-    (synopsis "Glimpse Image Editor")
-    (description "The Glimpse Image Editor is an application for image
-manipulation tasks such as photo retouching, composition and authoring.
-It supports all common image formats as well as specialized ones.  It
-features a highly customizable interface that is extensible via a plugin
-system.  It was forked from the GNU Image Manipulation Program.")
-    (license license:gpl3+)))