summary refs log tree commit diff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-13 20:26:21 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-13 20:26:21 +0200
commitfc58cb5bd2f4a4fb9e910f553009fce8a60e56e9 (patch)
tree5a69fa6b63a7bfe7232cb98e949912c20775058d /gnu/packages/gimp.scm
parent9d89818a359dd0657e4eb7649b29ad4197b8db39 (diff)
parentbad368b0d794689f3a8a11b58f1ea4987938682e (diff)
downloadguix-fc58cb5bd2f4a4fb9e910f553009fce8a60e56e9.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm83
1 files changed, 46 insertions, 37 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 5966906954..2a0ca3ac25 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016, 2018 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
@@ -191,7 +191,7 @@ buffers.")
        ("gexiv2" ,gexiv2)
        ("gtk+" ,gtk+-2)
        ("libmypaint" ,libmypaint)
-       ("mypaint-brushes" ,mypaint-brushes)
+       ("mypaint-brushes" ,mypaint-brushes-1.3)
        ("exif" ,libexif)                ; optional, EXIF + XMP support
        ("lcms" ,lcms)                   ; optional, color management
        ("librsvg" ,librsvg)             ; optional, SVG support
@@ -278,7 +278,7 @@ inverse fourier transform.")
 (define-public libmypaint
   (package
     (name "libmypaint")
-    (version "1.3.0")
+    (version "1.5.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/mypaint/libmypaint/"
@@ -286,7 +286,7 @@ inverse fourier transform.")
                                   version ".tar.xz"))
               (sha256
                (base32
-                "0wd6jk69vmhsq1mdw96v0fh7b28n3glkr5ca466zcq7agzaxj1va"))))
+                "0aqcv4fyscpfhknxgfpq0v84aj2nzigqvpi4zgv2zkl41h51by5f"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("intltool" ,intltool)
@@ -306,34 +306,42 @@ brushstrokes which is used by MyPaint and GIMP.")
 (define-public mypaint-brushes
   (package
     (name "mypaint-brushes")
-    (version "1.3.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/Jehan/mypaint-brushes.git")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1iz89z6v2mp8j1lrf942k561s8311i3s34ap36wh4rybb2lq15m0"))))
+    (version "2.0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mypaint/mypaint-brushes.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0kcqz13vzpy24dhmrx9hbs6s7hqb8y305vciznm15h277sabpmw9"))))
     (build-system gnu-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'relax-dependency-version
-           (lambda _
-             (substitute* "autogen.sh"
-               (("automake-1.13") "automake")
-               (("aclocal-1.13") "aclocal"))
-             #t)))))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)))
     (synopsis "Default brushes for MyPaint")
     (description "This package provides the default set of brushes for
 MyPaint.")
-    (home-page "https://github.com/Jehan/mypaint-brushes")
-    (license license:cc0)))
+    (home-page "https://github.com/mypaint/mypaint-brushes/")
+    ;; Scripts are distributed under GPL2+ terms, brushes are provided as
+    ;; public domain or under CC0 terms.
+    (license (list license:gpl2+ license:cc0 license:public-domain))))
+
+(define-public mypaint-brushes-1.3
+  (package
+    (inherit mypaint-brushes)
+    (name "mypaint-brushes")
+    (version "1.3.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mypaint/mypaint-brushes.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1c95l1vfz7sbrdlzrbz7h1p6s1k113kyjfd9wfnxlm0p6562cz3j"))))))
 
 (define-public gimp-resynthesizer
   ;; GIMP does not respect any plugin search path environment variable, so after
@@ -345,13 +353,14 @@ MyPaint.")
     (version "2.0.3")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/bootchk/resynthesizer/archive/v"
-			   version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/bootchk/resynthesizer")
+              (commit (string-append "v" version))))
        (sha256
         (base32
-         "0l3404w6rqny7h3djskxf149gzx6x4qhndgbh3403c9lbh4pi1kr"))
-       (file-name (string-append name "-" version ".tar.gz"))))
+         "1jwc8bhhm21xhrgw56nzbma6fwg59gc8anlmyns7jdiw83y0zx3j"))
+       (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments
      `( ;; Turn off tests to avoid:
@@ -359,11 +368,11 @@ MyPaint.")
        #:tests? #f
        #:phases
        (modify-phases %standard-phases
-	 (add-after 'unpack 'set-env
-	   (lambda _
-	     (setenv "CONFIG_SHELL" (which "sh"))
-	     #t))
-	 (add-after 'configure 'set-prefix
+         (add-after 'unpack 'set-env
+           (lambda _
+             (setenv "CONFIG_SHELL" (which "sh"))
+             #t))
+         (add-after 'configure 'set-prefix
            ;; Install plugin under $prefix, not under GIMP's libdir.
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((target (string-append (assoc-ref outputs "out")
@@ -372,8 +381,8 @@ MyPaint.")
                                             (package-version gimp))
                                           ".0")))
                (substitute* (list "src/resynthesizer/Makefile"
-				  "src/resynthesizer-gui/Makefile")
-		 (("GIMP_LIBDIR = .*")
+                                  "src/resynthesizer-gui/Makefile")
+                 (("GIMP_LIBDIR = .*")
                   (string-append "GIMP_LIBDIR = " target "\n")))
                (mkdir-p target)
                #t))))))