summary refs log tree commit diff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-10 00:31:43 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-10 00:32:23 +0100
commit5128252493dca8c0da6db2bc22dd88ebcdf5543a (patch)
tree4bf9c391c0fc871f4af7df06e83e37e46a663107 /gnu/packages/gimp.scm
parentbd70db6ee88838deb319aa54a1e2d8819413be10 (diff)
downloadguix-5128252493dca8c0da6db2bc22dd88ebcdf5543a.tar.gz
gnu: gegl: Update to 0.4.18.
* gnu/packages/gimp.scm (gegl): Update to 0.4.18.
[build-system]: Switch to Meson.
[arguments]: Disable GObject introspection.  Remove LDFLAGS fix.
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 6a16a39007..79ce01ed47 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -89,7 +89,7 @@ provided, as well as a framework to add new color models and data types.")
 (define-public gegl
   (package
     (name "gegl")
-    (version "0.4.16")
+    (version "0.4.18")
     (source (origin
               (method url-fetch)
               (uri (list (string-append "https://download.gimp.org/pub/gegl/"
@@ -103,10 +103,11 @@ provided, as well as a framework to add new color models and data types.")
                                         "/gegl-" version ".tar.xz")))
               (sha256
                (base32
-                "0njydcr6qdmfzh4fxx544681qxdpf7y6b2f47jcypn810dlxy4h1"))))
-    (build-system gnu-build-system)
+                "0r6akqnrkvxizyhyi8sv40mxm7j4bcwjb6mqjpxy0zzbbfsdyin9"))))
+    (build-system meson-build-system)
     (arguments
-     '(#:configure-flags '("LDFLAGS=-lm")))
+     `(#:configure-flags
+       (list "-Dintrospection=false")))
     ;; These are propagated to satisfy 'gegl-0.4.pc'.
     (propagated-inputs
      `(("babl" ,babl)