summary refs log tree commit diff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-27 22:01:32 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:24 -0500
commitc60449434bf64d42ba5c2de456823448088d3573 (patch)
treebf331cab3abbde6f5f0e8fba6e61027c57509c43 /gnu/packages/gl.scm
parenta4ad0187d38325531b02062b46c552d1a52511bd (diff)
downloadguix-c60449434bf64d42ba5c2de456823448088d3573.tar.gz
gnu: mesa: Replace obsolete vulkan-overlay-layer build option.
The option has been replaced by `vulkan-layers', an array of options.

* gnu/packages/gl.scm (mesa): Remove trailing #t.
[configure-flags]: Replace the vulkan-overlay-layer build option by
vulkan-layers.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index ccb78675f4..7756acbb58 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -332,7 +332,7 @@ also known as DXTn or DXTC) for Mesa.")
          ;; Enable the Vulkan overlay layer on architectures using llvm.
          ,@(match (%current-system)
              ((or "x86_64-linux" "i686-linux" "powerpc64le-linux" "aarch64-linux" "powerpc-linux")
-              '("-Dvulkan-overlay-layer=true"))
+              '("-Dvulkan-layers=device-select,overlay"))
              (_
               '()))
 
@@ -400,8 +400,7 @@ also known as DXTn or DXTC) for Mesa.")
            (lambda _
              ;; See <https://gitlab.freedesktop.org/mesa/mesa/-/issues/3181>.
              (substitute* "src/compiler/glsl/glcpp/tests/084-unbalanced-parentheses.c.expected"
-              (("unexpected \\$end") "unexpected end of file"))
-             #t))
+              (("unexpected \\$end") "unexpected end of file"))))
          (add-before 'configure 'fix-dlopen-libnames
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
@@ -419,8 +418,7 @@ also known as DXTn or DXTC) for Mesa.")
                  ;; it's never installed since Mesa removed its
                  ;; egl_gallium support.
                  (("\"gbm_dri\\.so")
-                  (string-append "\"" out "/lib/dri/gbm_dri.so")))
-               #t)))
+                  (string-append "\"" out "/lib/dri/gbm_dri.so"))))))
          (add-after 'install 'split-outputs
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))
@@ -465,8 +463,7 @@ also known as DXTn or DXTC) for Mesa.")
                                                        file)
                                               (symlink reference file)))
                                         others))))
-                         (delete-duplicates inodes))
-               #t))))))
+                         (delete-duplicates inodes))))))))
     (home-page "https://mesa3d.org/")
     (synopsis "OpenGL and Vulkan implementations")
     (description "Mesa is a free implementation of the OpenGL and Vulkan