summary refs log tree commit diff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-30 20:06:02 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-30 20:07:50 +0200
commita59936e10a3cedcd4455bff08f6d709d08d6217b (patch)
treecd132cdf16c94e1d052aba6c7c0290634a52d669 /gnu/packages/gl.scm
parent572d7e6ce546e999997ca556ba39ee6340f91ead (diff)
downloadguix-a59936e10a3cedcd4455bff08f6d709d08d6217b.tar.gz
gnu: mesa: Use llvm-for-mesa.
* gnu/packages/gl.scm (mesa)[inputs]: Replace llvm with llvm-for-mesa.
(mesa-opencl)[native-inputs]: Replace clang with clang-15.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 3c99c3815d..5151ecdce4 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -5,7 +5,7 @@
 ;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016 Nikita <nikita@n0.is>
 ;;; Copyright © 2016, 2017, 2018, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017, 2018, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017-2019, 2021, 2023 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -298,8 +298,7 @@ also known as DXTn or DXTC) for Mesa.")
            libxml2
            libxrandr
            libxvmc
-           ;; Note: update the 'clang' input of mesa-opencl when bumping this.
-           llvm
+           llvm-for-mesa
            wayland
            wayland-protocols))
     (native-inputs
@@ -513,7 +512,7 @@ from software emulation to complete hardware acceleration for modern GPUs.")
        (prepend libclc)))
     (native-inputs
      (modify-inputs (package-native-inputs mesa)
-       (prepend clang)))))
+       (prepend clang-15)))))
 
 (define-public mesa-opencl-icd
   (package/inherit mesa-opencl