summary refs log tree commit diff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-09 14:11:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-09 17:47:46 +0300
commit57e59eddfbdfe2316e5f619cff9cdc49fbedeb7a (patch)
treed6b3884d46f55c3b7c3b24f9cf8e6fb504649d39 /gnu/packages/gl.scm
parent36cb285d61f99bbaa8f6e84e0ddeac3f788a2e16 (diff)
downloadguix-57e59eddfbdfe2316e5f619cff9cdc49fbedeb7a.tar.gz
gnu: mesa: Fix architecture matching when disabling tests.
* gnu/packages/gl.scm (mesa)[arguments]: Adjust architecture names in
custom 'disable-failing-test phase.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 7181923bea..d694c0a7cb 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -365,11 +365,11 @@ also known as DXTn or DXTC) for Mesa.")
          (add-after 'unpack 'disable-failing-test
            (lambda _
              ,@(match (%current-system)
-                 ("powerpc64le"
+                 ("powerpc64le-linux"
                   ;; Disable some of the llvmpipe tests.
                   `((substitute* "src/gallium/drivers/llvmpipe/lp_test_arit.c"
                       (("0\\.5, ") ""))))
-                 ("powerpc"
+                 ("powerpc-linux"
                   ;; There are some tests which fail specifically on powerpc.
                   `((substitute* '(;; LLVM ERROR: Relocation type not implemented yet!
                                    "src/gallium/drivers/llvmpipe/meson.build"