summary refs log tree commit diff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-12-25 21:55:12 +0100
committerRutger Helling <rhelling@mykolab.com>2017-12-27 23:22:34 +0100
commit771d18162d33fdbaa0f4297df2ede0e70cd2732f (patch)
tree86b7e05fea99f42dcf065eb98be00fa9d8ebc811 /gnu/packages/gl.scm
parent80f642acd48831b3459c99b53c23bbab462ed0e4 (diff)
downloadguix-771d18162d33fdbaa0f4297df2ede0e70cd2732f.tar.gz
gnu: mesa: Update to 17.3.1.
* gnu/packages/gl.scm (mesa): Update to 17.3.1.
[inputs]: Remove s2tc.
[native-inputs]: Add python2-mako.
[arguments]: Add radeonsi to --with-gallium-drivers (exclude aarch64 and armhf).
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 7de2ca51fb..af5fb1b70e 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -221,7 +221,7 @@ also known as DXTn or DXTC) for Mesa.")
 (define-public mesa
   (package
     (name "mesa")
-    (version "17.2.7")
+    (version "17.3.1")
     (source
       (origin
         (method url-fetch)
@@ -233,7 +233,7 @@ also known as DXTn or DXTC) for Mesa.")
                                   version "/mesa-" version ".tar.xz")))
         (sha256
          (base32
-          "0s3slgjxnx482yw0knn4a6alsy2cq28rah6hnjbmf12mvyldxksh"))
+          "1h94m2nkxa1y4n415d5idk2x2lkgbvjcikv6r2r6yn4ak7h0grls"))
         (patches
          (search-patches "mesa-wayland-egl-symbols-check-mips.patch"
                          "mesa-skip-disk-cache-test.patch"))))
@@ -264,12 +264,12 @@ also known as DXTn or DXTC) for Mesa.")
              `()))
         ("makedepend" ,makedepend)
         ("presentproto" ,presentproto)
-        ("s2tc" ,s2tc)
         ("wayland" ,wayland)
         ("wayland-protocols" ,wayland-protocols)))
     (native-inputs
       `(("pkg-config" ,pkg-config)
         ("python" ,python-2)
+        ("python2-mako" ,python2-mako)
         ("which" ,(@ (gnu packages base) which))))
     (arguments
      `(#:configure-flags
@@ -281,7 +281,7 @@ also known as DXTn or DXTC) for Mesa.")
               ;; TODO: Fix svga driver for aarch64 and armhf.
               '("--with-gallium-drivers=freedreno,nouveau,r300,r600,swrast,vc4,virgl"))
              (_
-              '("--with-gallium-drivers=i915,nouveau,r300,r600,svga,swrast,virgl")))
+              '("--with-gallium-drivers=i915,nouveau,r300,r600,radeonsi,svga,swrast,virgl")))
          ;; Enable various optional features.  TODO: opencl requires libclc,
          ;; omx requires libomxil-bellagio
          "--with-platforms=x11,drm,wayland,surfaceless"