summary refs log tree commit diff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-07-18 18:37:58 +0200
committerDavid Craven <david@craven.ch>2016-08-22 22:17:57 +0200
commit8ea75f2723860470bd4d233aaa9ce6df5f8e8a5d (patch)
tree6c4e7033d2414fa0a1ee5fa411e4ea5f1d452f6d /gnu/packages/gl.scm
parente0b744f1a8ba76e24b079a2b94ef3cbcf109224a (diff)
downloadguix-8ea75f2723860470bd4d233aaa9ce6df5f8e8a5d.tar.gz
gnu: mesa: Enable wayland support.
* gnu/packages/gl.scm (mesa): Enable configure-flags required by wayland.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 7700609df2..f6ebc98f21 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -223,7 +223,8 @@ also known as DXTn or DXTC) for Mesa.")
         ("makedepend" ,makedepend)
         ("presentproto" ,presentproto)
         ("s2tc" ,s2tc)
-        ("udev" ,eudev)))
+        ("udev" ,eudev)
+        ("wayland" ,wayland)))
     (native-inputs
       `(("pkg-config" ,pkg-config)
         ("python" ,python-2)))
@@ -233,12 +234,16 @@ also known as DXTn or DXTC) for Mesa.")
          "--with-gallium-drivers=r600,svga,swrast,nouveau"
          ;; Enable various optional features.  TODO: opencl requires libclc,
          ;; omx requires libomxil-bellagio
-         "--with-egl-platforms=x11,drm"
+         "--with-egl-platforms=x11,drm,wayland"
          "--enable-glx-tls"        ;Thread Local Storage, improves performance
          ;; "--enable-opencl"
          ;; "--enable-omx"
          "--enable-osmesa"
          "--enable-xa"
+         ;; features required by wayland
+         "--enable-gles2"
+         "--enable-gbm"
+         "--enable-shared-glapi"
 
          ;; on non-intel systems, drop i915 and i965
          ;; from the default dri drivers