summary refs log tree commit diff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-09-05 20:38:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-09-05 21:52:09 +0300
commit665c0958d86d5c95d55bdc0e40cdc94e87fd99f3 (patch)
tree041c00b11036d0446d32158892ae8ef7ba7d6141 /gnu/packages/gl.scm
parent1f42989eb01b43f8f371f4a7c1667cf3c8a8c66b (diff)
downloadguix-665c0958d86d5c95d55bdc0e40cdc94e87fd99f3.tar.gz
gnu: mesa: Enable more drivers.
* gnu/packages/gl.scm (mesa)[arguments]: Split armhf and aarch64 driver
options, add more armhf specific drivers. Add offscreen platform.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index cc1dcf9edf..d8a69392b9 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -269,13 +269,15 @@ also known as DXTn or DXTC) for Mesa.")
     (arguments
      `(#:configure-flags
        '(,@(match (%current-system)
-             ((or "armhf-linux" "aarch64-linux")
+             ("armhf-linux"
+              '("--with-gallium-drivers=etnaviv,freedreno,imx,nouveau,r300,r600,svga,swrast,vc4,virgl"))
+             ("aarch64-linux"
               '("--with-gallium-drivers=freedreno,nouveau,r300,r600,svga,swrast,vc4,virgl"))
              (_
               '("--with-gallium-drivers=i915,nouveau,r300,r600,svga,swrast,virgl")))
          ;; Enable various optional features.  TODO: opencl requires libclc,
          ;; omx requires libomxil-bellagio
-         "--with-egl-platforms=x11,drm,wayland"
+         "--with-platforms=x11,drm,wayland,surfaceless"
          "--enable-glx-tls"        ;Thread Local Storage, improves performance
          ;; "--enable-opencl"
          ;; "--enable-omx"