summary refs log tree commit diff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-05-26 01:16:08 +0200
committerRutger Helling <rhelling@mykolab.com>2018-05-26 01:17:27 +0200
commita06e52279a223ff2d132e5ecefc0ebe73f51d4d7 (patch)
tree28759b2788227d3bcae78640b803ebff3d88d91a /gnu/packages/gl.scm
parent1fbad3ad224a92c8e2562b4f16ec20d8e9615fac (diff)
downloadguix-a06e52279a223ff2d132e5ecefc0ebe73f51d4d7.tar.gz
gnu: mesa: Restore wayland platform.
* gnu/packages/gl.scm (mesa)[arguments]: Restore wayland to --with-platforms for
now, since Wayland-EGL doesn't work properly without it.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 4d6cd705c3..323d279ea0 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -284,7 +284,7 @@ also known as DXTn or DXTC) for Mesa.")
               '("--with-gallium-drivers=i915,nouveau,r300,r600,radeonsi,svga,swrast,virgl")))
          ;; Enable various optional features.  TODO: opencl requires libclc,
          ;; omx requires libomxil-bellagio
-         "--with-platforms=x11,drm,surfaceless"
+         "--with-platforms=x11,drm,surfaceless,wayland"
          "--enable-glx-tls"        ;Thread Local Storage, improves performance
          ;; "--enable-opencl"
          ;; "--enable-omx"