summary refs log tree commit diff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-08-03 18:11:23 +0200
committerLudovic Courtès <ludo@gnu.org>2021-08-03 18:18:45 +0200
commit1685128e6e1147049feddee617a616ce7f3592c0 (patch)
tree5234e78d3034dfea96bb17e5a948e0d81a1082df /gnu/packages/gl.scm
parent2b6bf23c607705abe88d6874303c2fea05bceb63 (diff)
downloadguix-1685128e6e1147049feddee617a616ce7f3592c0.tar.gz
gnu: mesa-opencl, mesa-opencl-icd: Build all the LLVM targets again.
Reported by John Kehayias <john.kehayias@protonmail.com>
in <https://issues.guix.gnu.org/49794>.

* gnu/packages/patches/mesa-opencl-all-targets.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/gl.scm (mesa-opencl)[source]: Use it.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index e316352377..132dc63970 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -471,6 +471,10 @@ from software emulation to complete hardware acceleration for modern GPUs.")
 (define-public mesa-opencl
   (package/inherit mesa
     (name "mesa-opencl")
+    (source (origin
+              (inherit (package-source mesa))
+              (patches (cons (search-patch "mesa-opencl-all-targets.patch")
+                             (origin-patches (package-source mesa))))))
     (arguments
      (substitute-keyword-arguments (package-arguments mesa)
        ((#:configure-flags flags)