summary refs log tree commit diff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-03-06 11:31:35 +0800
committer宋文武 <iyzsong@gmail.com>2016-03-06 11:31:35 +0800
commit2a8b3b4e221f2e5e9e2b8718ab776262ec8facce (patch)
tree993d7cce6f45d7c6215c172b5219e26062e605e3 /gnu/packages/glib.scm
parent3b698589d25a2d491ff6bc154d78af4566c85f84 (diff)
downloadguix-2a8b3b4e221f2e5e9e2b8718ab776262ec8facce.tar.gz
gnu: dbus: Merge with dbus/activation.
* gnu/packages/glib.scm (dbus): Apply patch.
(dbus/activation): Remove.
* gnu/services/dbus.scm: Use 'dbus' instead of 'dbus/activation'.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index b925704aa0..0f06f7717c 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -61,14 +61,15 @@
     (name "dbus")
     (version "1.10.0")
     (source (origin
-              ;; TODO: Apply patch from DBUS/ACTIVATION below.
               (method url-fetch)
               (uri (string-append
                     "https://dbus.freedesktop.org/releases/dbus/dbus-"
                     version ".tar.gz"))
               (sha256
                (base32
-                "0jwj7wlrhq5y0fwfh8k2d9rgdpfax06lj8698g6iqbwrzd2rgyqx"))))
+                "0jwj7wlrhq5y0fwfh8k2d9rgdpfax06lj8698g6iqbwrzd2rgyqx"))
+              (patches
+               (list (search-patch "dbus-helper-search-path.patch")))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags
@@ -126,17 +127,6 @@ or through unencrypted TCP/IP suitable for use behind a firewall with
 shared NFS home directories.")
     (license license:gpl2+)))                     ; or Academic Free License 2.1
 
-(define-public dbus/activation
-  ;; D-Bus with a patch to fix service activation.
-  ;; TODO: Merge with DBUS above.
-  (package
-    (inherit dbus)
-    (version (string-append (package-version dbus) ".a"))
-    (source (origin
-              (inherit (package-source dbus))
-              (patches
-               (list (search-patch "dbus-helper-search-path.patch")))))))
-
 (define glib
   (package
    (name "glib")