summary refs log tree commit diff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-11-02 22:24:24 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-02 22:24:24 +0100
commitb4c22f25468cbb0b1644194381b25c795502bc16 (patch)
tree1f33dfd08b808a8e5c9518c78012b8b80e8d9016 /gnu/packages/glib.scm
parent5146f22b3b1615ed9d10796a0b1fffdf617138ef (diff)
parent77576be41f3b94c0f47457d338ddbbc8bf870ba9 (diff)
downloadguix-b4c22f25468cbb0b1644194381b25c795502bc16.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index ffa008d612..6cf235960c 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -391,29 +391,28 @@ The intltool collection can be used to do these things:
 (define itstool
   (package
     (name "itstool")
-    (version "2.0.2")
+    (version "2.0.4")
     (source (origin
              (method url-fetch)
              (uri (string-append "http://files.itstool.org/itstool/itstool-"
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "0fh34wi52i0qikgvlmrcpf1vx6gc1xqdad4539l4d9hikfsrz45z"))))
+               "0q7b4qrc758zfx3adsgvz0r93swdbxjr42w37rahngm33nshihlp"))))
     (build-system gnu-build-system)
     (inputs
      `(("libxml2" ,libxml2)
-       ("python2-libxml2" ,python2-libxml2)
-       ("python-2" ,python-2)))
+       ("python-libxml2" ,python-libxml2)
+       ("python" ,python)))
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-after
-          'install 'wrap-program
-          (lambda* (#:key outputs #:allow-other-keys)
-            (let ((prog (string-append (assoc-ref outputs "out")
-                                       "/bin/itstool")))
-              (wrap-program prog
-                `("PYTHONPATH" = (,(getenv "PYTHONPATH"))))))))))
+         (add-after 'install 'wrap-program
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((prog (string-append (assoc-ref outputs "out")
+                                        "/bin/itstool")))
+               (wrap-program prog
+                 `("PYTHONPATH" = (,(getenv "PYTHONPATH"))))))))))
     (home-page "http://www.itstool.org")
     (synopsis "Tool to translate XML documents with PO files")
     (description