summary refs log tree commit diff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-14 11:56:13 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-14 14:41:26 +0200
commitbbe04ae102211d6486691652a4892744ee7f9a85 (patch)
treebfd443b973245e420d3e27a7d05876d472f43dc6 /gnu/packages/glib.scm
parent9f7ae77fe287d7856718c5dfd60891be9b561b1d (diff)
downloadguix-bbe04ae102211d6486691652a4892744ee7f9a85.tar.gz
gnu: dbus: Update to 1.10.0.
* gnu/packages/glib.scm (dbus)[source]: Update to 1.10.0.
  [arguments]: Add --sysconfdir=/etc.
* gnu/packages/patches/dbus-localstatedir.patch: Update.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 2e8797560b..9137db3949 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -57,7 +57,7 @@
 (define dbus
   (package
     (name "dbus")
-    (version "1.8.16")
+    (version "1.10.0")
     (source (origin
              (method url-fetch)
              (uri
@@ -65,16 +65,21 @@
                              version ".tar.gz"))
              (sha256
               (base32
-               "01rba8mp8kqvmy6ibdmi806kjr3m14swnskqk02gyhykxxl54ybz"))
+               "0jwj7wlrhq5y0fwfh8k2d9rgdpfax06lj8698g6iqbwrzd2rgyqx"))
              (patches (list (search-patch "dbus-localstatedir.patch")))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags (list ;; Install the system bus socket under /var.
                                "--localstatedir=/var"
 
-                               ;; XXX: Fix the following to allow system-wide
-                               ;; config.
-                               ;; "--sysconfdir=/etc"
+                               ;; Look for configuration file under
+                               ;; /etc/dbus-1.  This is notably required by
+                               ;; 'dbus-daemon-launch-helper', which looks for
+                               ;; the 'system.conf' file in that place,
+                               ;; regardless of what '--config-file' was
+                               ;; passed to 'dbus-daemon' on the command line;
+                               ;; see <https://bugs.freedesktop.org/show_bug.cgi?id=92458>.
+                               "--sysconfdir=/etc"
 
                                "--with-session-socket-dir=/tmp")
        #:phases (alist-cons-after