summary refs log tree commit diff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
commit8c3e9da13a3c92a7db308db8c0d81cb474ad7799 (patch)
tree88d06952aa5cc3a9c4991d9c43eb7950ff174fe1 /gnu/packages/glib.scm
parent5439c04ebdb7b6405f5ea2446b375f1d155a8d95 (diff)
parent0c5299200ffcd16370f047b7ccb187c60f30da34 (diff)
downloadguix-8c3e9da13a3c92a7db308db8c0d81cb474ad7799.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm70
1 files changed, 1 insertions, 69 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 7bb0fdc9f4..95839a856d 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -812,44 +812,6 @@ useful for C++.")
       (modify-inputs (package-propagated-inputs glibmm)
         (replace "libsigc++" libsigc++-2)))))
 
-(define-public python2-pygobject-2
-  (package
-    (name "python2-pygobject")
-    ;; This was the last version to declare the 2.0 platform number, i.e. its
-    ;; pkg-config files were named pygobject-2.0.pc
-    (version "2.28.7")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "mirror://gnome/sources/pygobject/"
-                           (version-major+minor version)
-                           "/pygobject-" version ".tar.xz"))
-       (sha256
-        (base32
-         "0nkam61rsn7y3wik3vw46wk5q2cjfh2iph57hl9m39rc8jijb7dv"))
-       (patches (search-patches "python2-pygobject-2-deprecation.patch"))))
-    (build-system gnu-build-system)
-    (native-inputs
-     `(("which" ,which)
-       ("glib-bin" ,glib "bin")         ;for tests: glib-compile-schemas
-       ("pkg-config" ,pkg-config)
-       ("dbus" ,dbus)))                 ;for tests
-    (inputs
-     `(("python" ,python-2)
-       ("glib"   ,glib)
-       ("python2-pycairo" ,python2-pycairo)
-       ("gobject-introspection" ,gobject-introspection)))
-    (propagated-inputs
-     (list libffi))             ;mentioned in pygobject-2.0.pc
-    (arguments
-     `(#:tests? #f                      ;segfaults during tests
-       #:configure-flags '("LIBS=-lcairo-gobject")))
-    (home-page "https://pypi.org/project/PyGObject/")
-    (synopsis "Python bindings for GObject")
-    (description
-     "Python bindings for GLib, GObject, and GIO.")
-    (license license:lgpl2.1+)))
-
 (define-public python-pygobject
   (package
     (name "python-pygobject")
@@ -898,37 +860,7 @@ useful for C++.")
     (synopsis "Python bindings for GObject")
     (description
      "Python bindings for GLib, GObject, and GIO.")
-    (license license:lgpl2.1+)
-    (properties `((python2-variant . ,(delay python2-pygobject))))))
-
-(define-public python2-pygobject
-  (let ((base (strip-python2-variant python-pygobject)))
-    (package/inherit base
-      (name "python2-pygobject")
-
-      ;; Note: We use python-build-system here, because Meson only supports
-      ;; Python 3, and needs PYTHONPATH etc set up correctly, which makes it
-      ;; difficult to use for Python 2 projects.
-      (build-system python-build-system)
-      (arguments
-       `(#:python ,python-2
-         #:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'delete-broken-tests
-             (lambda _
-               ;; FIXME: this test freezes and times out.
-               (delete-file "tests/test_mainloop.py")
-               ;; FIXME: this test fails with this kind of error:
-               ;; AssertionError: <Handlers.SIG_IGN: 1> != <built-in function default_int_handler
-               (delete-file "tests/test_ossig.py")
-               #t)))))
-      (inputs
-       `(("python-pycairo" ,python2-pycairo)
-         ("gobject-introspection" ,gobject-introspection)))
-      (native-inputs
-       `(("glib-bin" ,glib "bin")
-         ("pkg-config" ,pkg-config)
-         ("python-pytest" ,python2-pytest))))))
+    (license license:lgpl2.1+)))
 
 (define-public perl-glib
   (package