summary refs log tree commit diff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-20 23:08:16 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-20 23:08:16 +0200
commit651478aa18a3f575d3b4cc14166a15a1c45b0f61 (patch)
tree87c27dc9eff3d321f7ad4a622b110c517856a104 /gnu/packages/glib.scm
parent71c08ee60bb3f62bac0614888fb62405f7a388ab (diff)
parent9a2e5fe5fdcc6ea848ceeefa0f70147dfb360639 (diff)
downloadguix-651478aa18a3f575d3b4cc14166a15a1c45b0f61.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index b5ddc19ef9..ab9ed0b1bf 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -80,6 +80,7 @@
   (package
     (name "dbus")
     (version "1.12.12")
+    (replacement dbus/fixed)
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -146,6 +147,14 @@ or through unencrypted TCP/IP suitable for use behind a firewall with
 shared NFS home directories.")
     (license license:gpl2+)))                     ; or Academic Free License 2.1
 
+(define dbus/fixed
+  (package
+    (inherit dbus)
+    (source (origin
+              (inherit (package-source dbus))
+              (patches (append (search-patches "dbus-CVE-2019-12749.patch")
+                               (origin-patches (package-source dbus))))))))
+
 (define glib
   (package
    (name "glib")