summary refs log tree commit diff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-20 23:40:52 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-20 23:40:52 +0200
commita9a78d8bfbabcd306115684c99d3b2aa8fc75be8 (patch)
tree23b55e038d5433a985caa0fabe03b4027e1d2f8d /gnu/packages/glib.scm
parent6cb1ef9ea28ee14b3bb5442e8af1f54c27802f09 (diff)
downloadguix-a9a78d8bfbabcd306115684c99d3b2aa8fc75be8.tar.gz
gnu: dbus: Update to 1.12.16.
* gnu/packages/patches/dbus-CVE-2019-12749.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/glib.scm (dbus): Update to 1.12.16.
[replacement]: Remove.
(dbus/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index d93a928c20..9fba2310d6 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -82,8 +82,7 @@
 (define dbus
   (package
     (name "dbus")
-    (version "1.12.14")
-    (replacement dbus/fixed)
+    (version "1.12.16")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -91,7 +90,7 @@
                     version ".tar.gz"))
               (sha256
                (base32
-                "13aca7gzgl7z1dfdipfs23773w8n6z01d4rj5kmssv4gms8c5ya4"))
+                "107ckxaff1cv4q6kmfdi2fb1nlsv03312a7kf6lb4biglhpjv8jl"))
               (patches (search-patches "dbus-helper-search-path.patch"))))
     (build-system gnu-build-system)
     (arguments
@@ -157,14 +156,6 @@ or through unencrypted TCP/IP suitable for use behind a firewall with
 shared NFS home directories.")
     (license license:gpl2+)))                     ; or Academic Free License 2.1
 
-(define dbus/fixed
-  (package
-    (inherit dbus)
-    (source (origin
-              (inherit (package-source dbus))
-              (patches (append (search-patches "dbus-CVE-2019-12749.patch")
-                               (origin-patches (package-source dbus))))))))
-
 (define glib
   (package
    (name "glib")