summary refs log tree commit diff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-11-30 18:07:03 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-11-30 18:26:05 +0100
commit86cf191426534ba5eac15e02ae20b1a0ba7f0bf4 (patch)
tree71a41299dd783b73ec5d27ab22a02eca1f16d89c /gnu/packages/glib.scm
parent35bbe88b3c12402bd0648f1ce15a2977742f70a2 (diff)
downloadguix-86cf191426534ba5eac15e02ae20b1a0ba7f0bf4.tar.gz
gnu: dbus: Eliminate graft.
* gnu/packages/glib.scm (dbus)[replacement]: Remove field.
[version]: Update to 1.10.12.
[source]: Update hash.
(dbus-1.10.12): Remove variable.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm20
1 files changed, 2 insertions, 18 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 2b57f85d75..e7419fd88b 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -64,8 +64,7 @@
 (define dbus
   (package
     (name "dbus")
-    (replacement dbus-1.10.12)
-    (version "1.10.10")
+    (version "1.10.12")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -73,7 +72,7 @@
                     version ".tar.gz"))
               (sha256
                (base32
-                "0hwsfczhx2djmc9116vj5v230i7gpjihwh3vbljs1ldlk831v3wx"))
+                "0pa71vf5c0d7k3gni06iascmplj0j5g70wbc833ayvi71d1pj2i1"))
               (patches (search-patches "dbus-helper-search-path.patch"))))
     (build-system gnu-build-system)
     (arguments
@@ -132,21 +131,6 @@ or through unencrypted TCP/IP suitable for use behind a firewall with
 shared NFS home directories.")
     (license license:gpl2+)))                     ; or Academic Free License 2.1
 
-(define dbus-1.10.12
-  (package
-    (inherit dbus)
-    (name "dbus")
-    (source
-      (let ((version "1.10.12"))
-        (origin
-          (inherit (package-source dbus))
-          (uri (string-append
-                "https://dbus.freedesktop.org/releases/dbus/dbus-"
-                version ".tar.gz"))
-          (sha256
-           (base32
-            "0pa71vf5c0d7k3gni06iascmplj0j5g70wbc833ayvi71d1pj2i1")))))))
-
 (define glib
   (package
    (name "glib")