summary refs log tree commit diff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-14 13:13:04 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-14 15:57:40 +0200
commitdcd48bfd843df8ecc2c9d77d703f341771d8f815 (patch)
treefee372852d27f31f33db06e1034ddcfe9a094791 /gnu/packages/glib.scm
parent1d7ceabc092ddc381bd1ae31d3398f9cf095a1e6 (diff)
downloadguix-dcd48bfd843df8ecc2c9d77d703f341771d8f815.tar.gz
glib: Verify the cross-compiled python is used in installed scripts.
* gnu/packages/glib.scm (glib)[arguments]<#:disallowed-references>:
  Disallow the native python when cross-compiling.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 99f5c5d450..e4ebed7e2c 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -77,6 +77,8 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix utils)
+  #:use-module (guix gexp)
+  #:use-module (srfi srfi-26)
   #:use-module ((srfi srfi-1) #:hide (zip))
 
   ;; Export variables up-front to allow circular dependency with the 'xorg'
@@ -200,7 +202,15 @@ shared NFS home directories.")
                "static"                 ;static libraries
                "bin"))                  ;executables; depends on Python
     (arguments
-     `(#:disallowed-references (,tzdata-for-tests)
+     `(#:disallowed-references
+       (,tzdata-for-tests
+        ;; Verify glib-mkenums, gtester, ... use the cross-compiled
+        ;; python.
+        ,@(if (%current-target-system)
+              (map (cut gexp-input <> #:native? #t)
+                   `(,(this-package-native-input "python")
+                     ,(this-package-native-input "python-wrapper")))
+              '()))
        #:configure-flags '("--default-library=both"
                            "-Dman=true"
                            "-Dselinux=disabled")