summary refs log tree commit diff
path: root/gnu/packages/global.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /gnu/packages/global.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadguix-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to...
* gnu: ... this.  Update module names accordingly.
* Makefile.am: Adjust accordingly.
* po/POTFILES.in: Likewise.
* distro.scm: Search for files under /gnu/packages instead of
  /distro/packages.
* gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'gnu/packages/global.scm')
-rw-r--r--gnu/packages/global.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/global.scm b/gnu/packages/global.scm
new file mode 100644
index 0000000000..705efbbbed
--- /dev/null
+++ b/gnu/packages/global.scm
@@ -0,0 +1,58 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages global)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix licenses)
+  #:use-module (gnu packages ncurses)
+  #:use-module (gnu packages autotools)
+  #:use-module (distro))
+
+(define-public global                             ; a global variable
+  (package
+    (name "global")
+    (version "6.2.7")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnu/global/global-"
+                          version ".tar.gz"))
+      (sha256
+       (base32
+        "1dr250kz65wqpbms4lhz857mzmvmpmiaxgyqxvxkb4b0s840i14i"))))
+    (build-system gnu-build-system)
+    (inputs `(("ncurses" ,ncurses)
+              ("libtool" ,libtool)))
+    (arguments
+     `(#:configure-flags
+       (list (string-append "--with-ncurses="
+                            (assoc-ref %build-inputs "ncurses")))))
+    (home-page "http://www.gnu.org/software/global/")
+    (synopsis "GNU GLOBAL source code tag system")
+    (description
+     "GNU GLOBAL is a source code tagging system that works the same way
+across diverse environments (Emacs, vi, less, Bash, web browser, etc).
+You can locate specified objects in source files and move there easily.
+It is useful for hacking a large project containing many
+subdirectories, many #ifdef and many main() functions.  It is similar
+to ctags or etags but is different from them at the point of
+independence of any editor.  It runs on a UNIX (POSIX) compatible
+operating system like GNU and BSD.")
+    (license "GPLv3+")))