summary refs log tree commit diff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorSergio Pastor PĂ©rez <sergio.pastorperez@outlook.es>2023-10-06 18:02:11 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-07 11:29:47 -0400
commite328a5f746c2a159f4396ae3725836e8a894b42d (patch)
tree0bc862e29b3f1ec68fc59f49f95bbda6a78018fe /gnu/packages/gnome-xyz.scm
parentb566e1a98a74d84d3978cffefd05295602c9445d (diff)
downloadguix-e328a5f746c2a159f4396ae3725836e8a894b42d.tar.gz
gnu: Add gnome-shell-extension-night-theme-switcher.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-night-theme-switcher): New variable.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 8b5dc3030e..6b66658215 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1050,6 +1050,29 @@ scrollable tiling of windows and per monitor workspaces.  It's inspired by paper
 notebooks and tiling window managers.")
     (license license:gpl3)))
 
+(define-public gnome-shell-extension-night-theme-switcher
+  (package
+    (name "gnome-shell-extension-night-theme-switcher")
+    (version "65")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url
+              "https://gitlab.com/rmnvgr/nightthemeswitcher-gnome-shell-extension")
+             (commit version)))
+       (sha256
+        (base32 "0qhi2g2lh6m8vhrmmfi60977f0i4k9x1zj68lrvpzzlqndz8cgh9"))
+       (file-name (git-file-name name version))))
+    (build-system meson-build-system)
+    (native-inputs (list pkg-config (list glib "bin")))
+    (synopsis "Automatic theme switcher for GNOME Shell")
+    (description
+     "Automatically toggle your GNOME desktop's color scheme between light and
+dark, switch backgrounds and run custom commands at sunset and sunrise.")
+    (home-page "https://nightthemeswitcher.romainvigier.fr")
+    (license license:gpl2+)))
+
 (define-public gpaste
   (package
     (name "gpaste")