summary refs log tree commit diff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorCharles <charles.b.jackson@protonmail.com>2022-01-11 15:26:38 -0600
committerMathieu Othacehe <othacehe@gnu.org>2022-01-12 12:52:33 +0100
commit6af7e5da8b803af9c65e726d65b3195929fc51c9 (patch)
treebb52e866d65759b6c587a630a2a10cf58d36fbcf /gnu/packages/gnome-xyz.scm
parent027973721b964cef3441edf2cb7738257b36b962 (diff)
downloadguix-6af7e5da8b803af9c65e726d65b3195929fc51c9.tar.gz
gnu: gnome-xyz: Add gnome-shell-extension-burn-my-windows.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-burn-my-windows): New Variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 64f1f6e436..07ba71f4f4 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -824,6 +824,45 @@ style.")
 position when the mouse is moved rapidly.")
     (license license:gpl2)))
 
+(define-public gnome-shell-extension-burn-my-windows
+  (package
+    (name "gnome-shell-extension-burn-my-windows")
+    (version "7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Schneegans/Burn-My-Windows/")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32
+         "1513kh6dfvnaj5jq2mm7rv1k54v91hjckgim1dpqlxwnv4gi9krd"))
+       (file-name (git-file-name name version))))
+    (build-system copy-build-system)
+    (arguments
+     `(#:install-plan
+       '(("." ,(string-append
+                "share/gnome-shell/extensions/"
+                "burn-my-windows@schneegans.github.com")
+          #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
+                            "\\.xml$" "\\.compiled$" "\\.gresource$")))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'install 'compile-resources
+           (lambda _
+             (invoke "make" "resources/burn-my-windows.gresource")))
+         (add-before 'install 'compile-schemas
+           (lambda _
+             (with-directory-excursion "schemas"
+               (invoke "glib-compile-schemas" ".")))))))
+    (native-inputs
+     (list `(,glib "bin")))  ; for glib-compile-resources
+    (home-page "https://github.com/Schneegans/Burn-My-Windows")
+    (synopsis "Application closing effects extension")
+    (description "Burn My Windows is a shell extension that stylizes the
+animation of closing windowed applications.")
+    (license license:gpl3)))
+
 (define-public arc-theme
   (package
     (name "arc-theme")