summary refs log tree commit diff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2021-02-10 19:03:01 +0100
committer宋文武 <iyzsong@member.fsf.org>2021-02-11 18:15:26 +0800
commit91689b9e0836f07058dcef7b02af539ea42d0bc8 (patch)
tree8a4f90fa9b58e499ca28abd119984f30902fe365 /gnu/packages/gnome-xyz.scm
parentf72ff06ef8a83a78ad625fe50ee5bb618ea4f37c (diff)
downloadguix-91689b9e0836f07058dcef7b02af539ea42d0bc8.tar.gz
gnu: Add tiramisu.
* gnu/packages/gnome-xyz.scm (tiramisu): New variable.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index eb99fda78e..aa7949478c 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -9,6 +9,7 @@
 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
 ;;; Copyright © 2020 Ellis Kenyo <me@elken.dev>
+;;; Copyright © 2020 Stefan Reichör <stefan@xsteve.at>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -32,6 +33,7 @@
   #:use-module (guix build-system meson)
   #:use-module (guix git-download)
   #:use-module (guix packages)
+  #:use-module (guix utils)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
@@ -888,3 +890,42 @@ feature-set for programming Vala effectively.")
    (description "Nordic is a Gtk3.20+ theme created using the Nord color
 pallete.")
    (license license:gpl3))))
+
+(define-public tiramisu
+  (let ((commit "8eb946dae0e2f98d3850d89e1bb535640e8c3266")
+        (revision "0"))
+    (package
+      (name "tiramisu")
+      (version (git-version "1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/Sweets/tiramisu")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "0wz2r8369d40vnxswknx0zxzbs03gzv0nc8al4g0ffg972p15j25"))
+                (file-name (git-file-name name version))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (delete 'configure)
+           (delete 'check)
+           (replace 'install
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let ((out (assoc-ref outputs "out")))
+                 (install-file "tiramisu" (string-append out "/bin"))
+                 #t))))
+         #:make-flags
+         (list (string-append "CC=" ,(cc-for-target)))))
+      (inputs
+       `(("glib" ,glib)))
+      (native-inputs
+       `(("pkg-config" ,pkg-config)))
+      (home-page "https://github.com/Sweets/tiramisu")
+      (synopsis "Desktop notifications, the UNIX way")
+      (description "tiramisu is a notification daemon based on dunst that
+outputs notifications to STDOUT in order to allow the user to process
+notifications any way they prefer.")
+      (license license:expat))))